I have recently switched to the Colemak keyboard layout and the Ctrl+Alt+L key combination no longer locks the screen. I have checked the keyboard shortcuts menu and it is still set correctly.

I have also tried locking the screen using this combination in Dvorak, and the problem persists. Changing back to Qwerty restores the functionality, and although switching back is simple to do (another shortcut) it would be nice to be able to do this with Colemak.

There are other shortcuts that have also stopped working, so the problem is not specific to the lock shortcut:

  • Ctrl+D in terminal doesn't close the terminal.
  • My custom shortcut, Super+T won't open the terminal.

Running Ubuntu 10.04.


This question has a similar problem: Terminal Shortcut Key not respecting keyboard layout

Edit 2

Turns out this is a known bug: Why don't shortcut keys change when keyboard layout changes?

  • Try to reset the shortcut with Colemak keyboard, in keyboard settings. May 16 '12 at 20:09
  • I changed the shortcut to Ctrl+Alt+M in System -> Preferences -> Keyboard Shortcuts and that worked perfectly. Changing it back to L still did not work. Other letters such as Y and U did not work either.
    – Daniel
    May 17 '12 at 5:35
  • I opened the "Show Current Layout" screen and when I press Ctrl+Alt+L it does not seem to recognise the combination, however it will recognise Ctrl+Alt, and Ctrl+Alt+M.
    – Daniel
    May 17 '12 at 5:38
  • possible duplicate of Why don't shortcut keys change when keyboard layout changes? May 18 '12 at 14:35

it doesn't work because the keyboard layout is different, i mean where the keys are virtually so check the keyboard layout in the OS or change the language that it's in... i hope this was helpful

  • 1
    I want the keyboard layout to be Colemak, so yes, the virtual layout has changed. I am hitting the Ctrl+Alt+L keys in Colemak and it does not work. The same combination using the Qwerty locations also doesn't work, so it's clear that the shortcut isn't mapped to a physical location (which it shouldn't be). As mentioned in the question, changing the logical layout back to Qwerty resolves the issue, but I am trying to get it to work with Colemak.
    – Daniel
    May 17 '12 at 5:24

What solved the problem for me:

sudo add-apt-repository ppa:attente/java-non-latin-shortcuts 
sudo apt-get install unity-settings-daemon 
restart unity-settings-daemon

Details: https://bugs.launchpad.net/unity/+bug/1226962

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.