• Machine: Mac Mini (late 2009, Macmini3,1) with Ubuntu 20.04 LTS as only OS (only one partition)
  • Use: SOHO Samba server
  • Install: August 2021, upgraded all packages at that time but never upgraded since
  • GUI accessed using VNC from another Mac, (vino installed on problem machines)


  • All was well for weeks until the GUI locked up in VNC window. I switched the KVM for direct access but my monitor did not detect any signal at all from the problem computer. ‘Used the Mac Mini power button to force quit the machine, then restarted. GUI access was again available. Over the next few weeks, the problem would occasionally come up. Each time restarting would work. Until now.
  • Now the boot process starts out well: GRUB menu comes up and waits the 10 seconds per its configuration. (No difference if I choose “Ubuntu” at this point.) Immediately the screens changes to black with only a solid cursor in the upper left quadrant, NOT in the far upper left.
  • TTY is not available (Control - Option - F3 does nothing).
  • A second machine (the intended backup for first machine) is now beginning to show the same problems. Its specs are the same, except it has a larger HD and no production data. Ubuntu 20.04 LTS was installed on it 11/23/21 and all packages were then upgraded. Since the install the GUI has locked up twice. Each time switching KVM to direct access again shows no video at all. This second machine could be restarted to resume access, but I fear it won’t for long.


  1. Chose “Advance Options for Ubuntu” from the GRUB menu, and then the option…

     Ubuntu, with Linux 5.11.0-40-generic (recovery mode)

    ...the screen shows a few lines of responses, but stops at…

     [ 0.702010] Linux agpgart interface v0.103]

    ...and again TTY is not available.

  2. Choosing either of the two other available kernel’s recovery mode produces the same result as #1.

  3. This machine probably has an Nvidia graphics card (Apple specs show NVIDIA GeForce 9400M, but I can’t verify without terminal). So I’ve tried editing the GRUB commands to replace “quiet splash” with “nomodeset”. The results are the same as #1

  4. Attempted to boot from the Ubuntu 20.04 live USB gets stuck also, but at a different response line…

     [  0.852603] Initramfs unpacking failed:  Decoding failed

    …even though that very same USB drive was used to do the original install.

  5. Attempted to boot from a different USB, this one with Ubuntu 20.10, results in yet one more stopping point…

     [  0.279054] pic 000:02:00.0: error -61 assigning properties
  6. Attempted to boot from yet another USB, this one with Ubuntu 18.04 results in original problem: black screen with solid cursor

  7. Edited the GRUB commands in attempt to enter TTY (per https://askubuntu.com/a/760935/832994) by adding this to end of linux line…


    …but startup process locks after this response…

     Loading initial ramdisk…
  8. Edited GRUB commands, added nomodeset to end of Linux line, got same results as #7

  9. Theory: this is a video-only problem, but...

    • carefully entering my login credentials showed no response
    • machine does not respond to ssh or ping from another computer
  10. ‘Only just learned about Magic SysRq. Previously I did not adjust Ubuntu setup to enable this (still needed on 20.04?). Tried…

    Alt + SysRq, then reisub

    …but no response

  11. In GRUB command line interface…

    grub> ls -l /var/log

…doesn’t show any log file has been updated after the lockup, despite many boot attempts

    grub> cat /var/log/syslog

…also shows no log entries since after lockup


  1. How do I continue debugging this problem if TTY is unavailable and booting off of an external drive doesn’t work?
  2. This seems like it might be a video driver issue, but on two machines updated months apart?


You must log in to answer this question.

Browse other questions tagged .