I connected my Google Pixel 6, with the new Android 12, with my Ubuntu 20/04 Notebook via USB.

In Files I see the Pixel 6, on the phone. I activated:

  • Use USB for "File transfer / Android Auto".

But Files, after trying 20 seconds, tells me 'Unable to access "Pixel 6"'

Sure I can upload e.g. photos to google drive and copy them from there. But I would like to have a direct access to the file system which was no problem at all on my Samsung S9 / Android 8.

As well I tried toggling in between the options and reconnecting which both did not help.

Does anyone have a solution for this?

  • Does PTP (photos) work or shows the same symptom? Have you tried toggling "charging only" and back to MPT (file transfer)? Commented Nov 28, 2021 at 13:05
  • Ok, I got a "-1" for this question. Fair enough. But would you at least explain why this question shall be stupid?
    – Thomas R
    Commented Nov 28, 2021 at 13:06
  • 1
    I upvoted it to compensate and I was wondering the same. It's a perfectly valid on-topic question and other than the information I asked about in the first comment and, eventually, about whether or not you're using the original cable, there's no much that can be added. Please keep in mind you should edit the question to add any new info, corrections or other addendums, not just post it in comments. Commented Nov 28, 2021 at 13:09
  • @ChanganAuto no PTP does not work either and shows the same symptom. Toggling or reconnecting does not work either.
    – Thomas R
    Commented Nov 28, 2021 at 13:10
  • Again, please edit the question to add new info. Also, are you using the original cable? Commented Nov 28, 2021 at 13:12

3 Answers 3


Samsung smartphones and especially new generations with USB-C connectors are quite "picky" about the USB cables for anything else other than just charging. It's often recommended to always use the original cable or other third-party known-good cable.

The cable that was being used, a "USB2.0 - USB-C", doesn't work for file transfer. Replacing it with a direct USB-C cable solved the problem.


I solved this problem with a USB-C to USB-C cable that was originally intended for connecting an external portable monitor.

Perhaps another good solution, in general, is to choose a cable that is designed for fast data transfer.


I did some more tests.

Until now every test with a USB2-USB-C failed.

Additionally, if I use my USB-C-Connection which is generally used for loading, although the Pixel is recognized on my Notebook I can't transfer files.

My solution now was to use usb-c-cable from a charger and put then into my second usb-c-input on the notebook to make it work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .