0

I am in the process of moving from Windows to Linux, but I am getting this error while trying to visit certain websites. I am currently using Kubuntu 20.04, but have also tried Manjaro 20.1.6 and PopOS 20.04 and have had the same issue. However, everything works fine on my windows 10 partition. I have tried the fixes in this article, but they didn't work. My browser is Firefox 94.0 (the latest version), but I have also tried Brave and Chromium, but I just get a slightly different error message: ERR_SSL_VERSION_OR_CIPHER_MISMATCH. I have also tried using tethering from my phone, using my wifi and mobile data, but there is no change. Some websites that work are: askubuntu.com, mailbox.org, duckduckgo.com, google.co.uk, youtube.com and reddit.com. Some websites that don't work are: windscribe.com, protonvpn.com, store.steampowered.com and twitch.tv. A solution to this error, so I don't get it at all would be greatly appreciated.

1
  • There's not enough information here do any kind of debugging. This sounds like there's a bunch of different issues, really, and it's impossible to tell exactly what your question is here or what the actual problem you're asking about is.
    – Thomas Ward
    Nov 27, 2021 at 18:24

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.