2

I have a GP66 Leopard with this GPU:

anto@anto-GP66-Leopard-11UH:~$ lspci | grep -i nvidia
01:00.0 VGA compatible controller: NVIDIA Corporation GA104M [GeForce RTX 3080 Mobile / Max-Q 8GB/16GB] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GA104 High Definition Audio Controller (rev a1)

It seems to be CUDA-compatible according to NVDIA docs.

My ubuntu version is supported by the CUDA development tools:

anto@anto-GP66-Leopard-11UH:~$ uname -m && cat /etc/*release
x86_64
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=20.04
DISTRIB_CODENAME=focal
DISTRIB_DESCRIPTION="Ubuntu 20.04.3 LTS"
NAME="Ubuntu"
VERSION="20.04.3 LTS (Focal Fossa)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 20.04.3 LTS"
VERSION_ID="20.04"
HOME_URL="https://www.ubuntu.com/"
SUPPORT_URL="https://help.ubuntu.com/"
BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"
PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy"
VERSION_CODENAME=focal
UBUNTU_CODENAME=focal

I don't know if I have the correct headers and development packages:

anto@anto-GP66-Leopard-11UH:~$ uname -r
5.11.0-40-generic

But I installed the latest Nvidia Driver:

anto@anto-GP66-Leopard-11UH:~$ apt list --installed 'nvidia*'
Listing... Done
nvidia-container-toolkit/now 1.6.0-1 amd64 [installed,local]
nvidia-docker2/now 2.7.0-1 all [installed,local]
nvidia-utils-460-server/focal-updates,now 460.106.00-0ubuntu0.20.04.1 amd64 [installed]

But when I verify the installation

anto@anto-GP66-Leopard-11UH:~$ nvidia-smi
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

So how can I make GeForce RTX 3080 Mobile / Max-Q 8GB/16GB communicate with NVIDIA driver

Update for N0rbert

anto@anto-GP66-Leopard-11UH:~$ dpkg -l | grep -i nvidia
ii  libnvidia-cfg1-460-server:amd64            460.106.00-0ubuntu0.20.04.1           amd64        NVIDIA binary OpenGL/GLX configuration library
ii  libnvidia-compute-460-server:amd64         460.106.00-0ubuntu0.20.04.1           amd64        NVIDIA libcompute package
ii  libnvidia-container-tools                  1.6.0-1                               amd64        NVIDIA container runtime library (command-line tools)
ii  libnvidia-container1:amd64                 1.6.0-1                               amd64        NVIDIA container runtime library
ii  nvidia-container-toolkit                   1.6.0-1                               amd64        NVIDIA container runtime hook
ii  nvidia-docker2                             2.7.0-1                               all          nvidia-docker CLI wrapper
ii  nvidia-utils-460-server                    460.106.00-0ubuntu0.20.04.1           amd64        NVIDIA Server Driver support binaries
ii  xserver-xorg-video-nvidia-460-server       460.106.00-0ubuntu0.20.04.1           amd64        NVIDIA binary Xorg driver
anto@anto-GP66-Leopard-11UH:~$ lspci -k | grep -i nvidia -A3
01:00.0 VGA compatible controller: NVIDIA Corporation GA104M [GeForce RTX 3080 Mobile / Max-Q 8GB/16GB] (rev a1)
    Subsystem: Micro-Star International Co., Ltd. [MSI] Device 12fb
    Kernel driver in use: nouveau
    Kernel modules: nvidiafb, nouveau
01:00.1 Audio device: NVIDIA Corporation GA104 High Definition Audio Controller (rev a1)
    Subsystem: Micro-Star International Co., Ltd. [MSI] Device 12fb
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel
anto@anto-GP66-Leopard-11UH:~$ 
anto@anto-GP66-Leopard-11UH:~$ sudo ubuntu-drivers autoinstall
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-dkms-460-server : Depends: nvidia-kernel-common-460-server (<= 460.106.00-1) but it is not installable
                          Depends: nvidia-kernel-common-460-server (>= 460.106.00) but it is not installable
 nvidia-driver-460-server : Depends: nvidia-kernel-common-460-server (<= 460.106.00-1) but it is not installable
                            Depends: nvidia-kernel-common-460-server (>= 460.106.00) but it is not installable
                            Recommends: nvidia-settings but it is not going to be installed
                            Recommends: nvidia-prime (>= 0.8) but it is not going to be installed
                            Recommends: libnvidia-compute-460-server:i386 (= 460.106.00-0ubuntu0.20.04.1)
                            Recommends: libnvidia-decode-460-server:i386 (= 460.106.00-0ubuntu0.20.04.1)
                            Recommends: libnvidia-encode-460-server:i386 (= 460.106.00-0ubuntu0.20.04.1)
                            Recommends: libnvidia-ifr1-460-server:i386 (= 460.106.00-0ubuntu0.20.04.1)
                            Recommends: libnvidia-fbc1-460-server:i386 (= 460.106.00-0ubuntu0.20.04.1)
                            Recommends: libnvidia-gl-460-server:i386 (= 460.106.00-0ubuntu0.20.04.1)
E: Unable to correct problems, you have held broken packages.
2
  • Please share output of dpkg -l | grep -i nvidia, lspci -k | grep -i nvidia -A3 .
    – N0rbert
    Nov 26 '21 at 14:29
  • Sure, Just did it @N0rbert Nov 26 '21 at 14:47
3

Really you do not have proper proprietary Nvidia driver installed.
Driver in use is shown in lspci -k output - "Kernel driver in use: nouveau".

At first run sudo apt-get update then you can use one of the below methods:

  • use nvidia-drivers tool to auto install it

    sudo ubuntu-drivers autoinstall
    
  • install drivers using GUI - launch Software & Updates (software-properties-gtk) and install Nvidia driver from Additional drivers tab

  • install latest 470 using bruteforce :)

    sudo apt-get install nvidia*470 cuda*470 nvidia-cuda-toolkit
    

then reboot.


Please note that apt search nvidia-driver will show the list of search results, not only installed packages (installed are marked as ... now ... [installed], but they are hard to find).
To get the list of installed packages you have to use apt list --installed 'nvidia*' or dpkg -l | grep -i nvidia.

5
  • Thanks for your answer! I thought it could have solved it. But while running your command my downloaded packages have unmet dependencies. Do you know how I can cope with that? Nov 26 '21 at 15:27
  • Then if you are using Ubuntu desktop - run software-properties-gtk and switch to Drivers tab. And then install latest driver from there.
    – N0rbert
    Nov 26 '21 at 15:35
  • The 495 driver is in the standard repos now, I just updated from 470, and it works fine for me, even though it's not "recommended or tested" -- maybe try that.
    – ubfan1
    Nov 26 '21 at 18:09
  • Let's finish with 470. It is recommended by the vendor, as stable branch. And has relevant CUDA fabric package. I'm waiting for the response from OP and wish best user experience with such great hardware.
    – N0rbert
    Nov 26 '21 at 18:10
  • 1
    Fix the dependencies. It's not explained in this question but you should always run sudo apt update before you do anything else in apt and you really should also run sudo apt upgrade as well before you add/remove/change any other software.
    – Nmath
    Nov 26 '21 at 19:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.