2

I Have full amd laptop and and i have RZ608 (MT7921K) and ubuntu does not find the module so the driver is missing. I tried to find a driver and only solution show up was updating kernel to 5.14+. I updated but still had the same issue. Additionally, in MediaTek i only saw upto MT7921 supported by kernel version 5.12+ not MT7921K so where can i find a driver for this module. Any help is appreciated.

The output of lspci -nnk | grep 0280 -A3:

05:00.0 Network controller [0280]: MEDIATEK Corp. Device [14c3:0608]
    Subsystem: MEDIATEK Corp. Device [14c3:0608]
06:00.0 Non-Volatile memory controller [0108]: Kingston Technology Company, Inc. Device [2646:500c] (rev 01)
    Subsystem: Kingston Technology Company, Inc. Device [2646:500c]

The output of:

wget https://gitlab.com/jeremy53561/backports-11-26/-/raw/main/backports-5.15-rc6-1.tar.gz

--2021-11-27 16:56:21--  https://gitlab.com/jeremy53561/backports-11-26/-/raw/main/backports-5.15-rc6-1.tar.gz
Resolving gitlab.com (gitlab.com)... 172.65.251.78, 2606:4700:90:0:f22e:fbec:5bed:a9b9
Connecting to gitlab.com (gitlab.com)|172.65.251.78|:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://gitlab.com/users/sign_in [following]
--2021-11-27 16:56:21--  https://gitlab.com/users/sign_in
Reusing existing connection to gitlab.com:443.
HTTP request sent, awaiting response... 503 Service Temporarily Unavailable
2021-11-27 16:56:21 ERROR 503: Service Temporarily Unavailable.

Hey i get the file in the first link from linux server as .xz file and tried to do the:

make defconfig-wifi

result is:

lex -ozconf.lex.c -L zconf.l
make[2]: lex: Command not found
Makefile:23: recipe for target 'zconf.lex.c' failed
make[2]: *** [zconf.lex.c] Error 127
Makefile.real:41: recipe for target 'defconfig-wifi' failed
make[1]: *** [defconfig-wifi] Error 2
Makefile:40: recipe for target 'defconfig-wifi' failed
make: *** [defconfig-wifi] Error 2

Okay, i checked all your comments and answers then realized that you all suggest to install some files into mediatek folder like WIFI_RAM_CODE etc. I checked all these files already installed i have disabled secure boot and your other suggestion like updating kernel and upgrading ubuntu. The result is Bluetooth works but still wi-fi adapter is missing.I have a dual-boot and in windows it works like charm. I don't know what is causing the problem. Thanks for your attention.

Suddenly it started working. I think it may because disabling secure boot, updating kernel and ubuntu version, adding the patches. Suddenly it worked. I checked the kernel version currently it is 5.15.5-051505-generic. I am planning to reinstall ubuntu and i will update the post on initializing the RZ608. Thanks.

4
  • 2
    Let's start by identifying your exact device. Please edit your question to show the result of the terminal command: lspci -nnk | grep 0280 -A3 Welcome to Ask Ubuntu.
    – chili555
    Nov 21, 2021 at 22:46
  • hi @chili555, i added the output of the code you suggested. Thanks for your interest i was unavailable at time you asked. I am sorry for late reply.
    – tealy
    Nov 25, 2021 at 10:24
  • Possibly helpful: spinics.net/lists/linux-wireless/msg217303.html I'm studying about how to utilize this information.
    – chili555
    Nov 25, 2021 at 16:56
  • Do sudo apt install flex bison then do make clean && make defconfig-wifi and see if it goes farther and says something about written to .config at the last liine
    – Jeremy31
    Nov 27, 2021 at 18:03

4 Answers 4

5

Just for the record, Linux kernel's driver module mt7921e does work with this card. I'm on 5.15.2. If you already have this module, you won't need anything other than some configs to workaround this for now.

But, for now it seems that this module currently doesn't include a match for this card's id until this patch hit: https://patchwork.kernel.org/project/linux-wireless/patch/84ab45bf42f57fd0301c156ffc11d0fe330ff1f8.1636857817.git.deren.wu@mediatek.com/

So, currently I'm using a modprobe rule and a udev rule to automatically load the module and use it for the card.

$ cat /etc/modprobe.d/rz608.conf
alias pci:v000014C3d00000608sv*sd*bc*sc*i* mt7921e

$ cat /etc/udev/rules.d/99-rz608.rules
SUBSYSTEM=="drivers", DEVPATH=="/bus/pci/drivers/mt7921e", ATTR{new_id}="14c3 0608"

If you only need it to work for this boot:

# modprobe mt7921e
# echo 14c3 0608 > /sys/bus/pci/drivers/mt7921e/new_id

  1. Modalias
  2. udev(7)
3

In terminal

sudo apt install build-essential flex bison
wget https://gitlab.com/jeremy53561/backports-11-26/-/raw/main/backports-5.15-rc6-1.tar.gz
tar -xvf backports-5.15-rc6-1.tar.gz
cd backports-5.15-rc6-1
make clean
make defconfig-wifi
make
sudo make install
cd /lib/firmware/mediatek
sudo wget https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/plain/mediatek/WIFI_MT7961_patch_mcu_1_2_hdr.bin
sudo wget https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/plain/mediatek/WIFI_RAM_CODE_MT7961_1.bin

Check Secure boot status with mokutil --sb-state as Secure Boot needs to be disabled in UEFI settings for the unsigned module to be loaded

Reboot

8
0

I am running ubuntu 20.04 on an ACER Aspire-5 which uses an MT7921. Same problem as the OP - no WiFi.

My solution was to install the missing firmware files and WiFi now works. Bluetooth works too.

Do check that you do not already have the required /lib/firmware/mediatek/ files.

mkdir x
cd x
wget 'http://http.us.debian.org/debian/pool/non-free/f/firmware-nonfree/firmware-misc-nonfree_20210818-1_all.deb'
ar x firmware-misc-nonfree_20210818-1_all.deb
tar x -f data.tar.xz
sudo cp -a lib/firmware/mediatek/WIFI_MT7961_patch_mcu_1_2_hdr.bin /lib/firmware/mediatek/
sudo cp -a lib/firmware/mediatek/WIFI_RAM_CODE_MT7961_1.bin /lib/firmware/mediatek/
sudo cp -a lib/firmware/mediatek/BT_RAM_CODE_MT7961_1_2_hdr.bin /lib/firmware/mediatek/
0

I've head some really weird behavior both in Windows and Linux for the exact same adapter and the mt7921e kernel module. I was able to fix the issue with the help of clearing the CMOS state on my motherboard (by temporary shorting the necessary pins as the manual says. The adaptor was built-in into the motherboard. Leaving it here, hoping this can actually help someone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.