Ok... I tried GIMP 2.8, but felt more comfortable with 2.6. I removed the PPA's from Ubuntu Software Centre, removed and purged GIMP, and even rm the .gimp-2.8 folder. But when I go to install GIMP via terminal or the Software Centre I encounter this problem.

I know I should have known better, I had a VERY similar problem with 2.7. I tried those suggestions that worked for me last time, but I cannot get 2.6 back, see below for my error.

I am using Ubuntu 12.04 32 bit.

Thank you for your time and answers.

GIMP dependencies error


OK, I just tried this on 12.04 64-bit, had the same problem, here's how I fixed it:

  • Open a terminal with Ctrl+Alt+T
  • Type these, one after the other:

    sudo add-apt-repository -r ppa:otto-kesselgulasch/gimp
    sudo apt-get update
    sudo apt-get remove gimp.* -y
    sudo apt-get autoremove -y
    sudo apt-get install gimp=2.6.12-1ubuntu1
  • If it gives you dependency errors at any point and asks you to run sudo apt-get -f install, do so and then resume from that point.

  • Does anyone know if this answer will work on 12.10? And xubuntu, rather than ubuntu? I can't find the "otto-kesselgulasch" repository in /etc/apt/sources.list, so I wonder whether it's necessary anymore? – Ash Mar 5 '13 at 13:31
  • For anyone looking for a 12.10 "revert to gimp 2.6" solution, I found this one worked: askubuntu.com/a/243873/121193 – Ash Mar 6 '13 at 11:06

You can use YPPA Manager to purge the PPA.

This then should revert you back to the standard libraries. From there you can reinstall GIMP 2.6

ref: http://www.makeuseof.com/tag/ppa-manage-gui-managing-ubuntu-ppas-linux/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.