1

I am looking for a driver for the TP-Link AC600 Archer T2U Plus, on Uubuntu 20.04 (kernel version 5.11.0-40-generic).

$ lsusb
Bus 005 Device 002: ID 2357:0120 TP-Link 802.11ac WLAN Adapter

$ inxi -N | grep "TP-Link"
  Device-2: TP-Link 802.11ac WLAN Adapter type: USB driver: usb-network

I installed a driver and it worked for the first time, when I opened the coputer today, the adaptater doesn't give me any Wi-Fi network.

1
  • 1
    Install the driver again. If you didn't use dkms, you need to install it after each kernel upgrade.
    – Pilot6
    Nov 21, 2021 at 17:35

2 Answers 2

2

I resolve it. I reinstalled the driver with this commands:

sudo apt install git dkms
git clone https://github.com/aircrack-ng/rtl8812au.git
cd rtl8812au
sudo make dkms_install

If you don't hace permission try to execute:

chmod 777 rtl8812au
2
  • I'm facing the same problem as op and using chmod 777 rtl8812au command didn't help. The connection is wiped out after i restart my computer. Also I can't connect to the 5Ghz band. How to connect to 5Ghz with T2U plus?
    – skekmal
    Jun 8 at 15:05
  • I had to fight a lot to find a usefull solution and a found some that I don't remeber. The last one I did was starting the process from 0. I mean to remove dkms and git and then follow the same commands again. Try with sudo apt remove dkms git. Jun 9 at 23:10
0

I get this error:

Error! DKMS tree already contains: 8812au-5.6.4.2_35491.20191025

You cannot add the same module/version combo more than once. make: *** [Makefile:2317: dkms_install] Error 3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.