0

I having trouble with running command: sudo apt-get update I have below errors. Do you have any ideas and suggestions, please? Thank you!

Err:2 http://es-mirrors.evowise.com/ubuntu impish InRelease
  Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?)
Err:3 http://es-mirrors.evowise.com/ubuntu impish-updates InRelease
  Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?)
Err:4 http://es-mirrors.evowise.com/ubuntu impish-backports InRelease
  Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?)
Err:6 http://es-mirrors.evowise.com/ubuntu impish-security InRelease
  Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?)
Reading package lists... Done 
N: See apt-secure(8) manpage for repository creation and user configuration details.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
E: The repository 'http://es-mirrors.evowise.com/ubuntu impish InRelease' is not signed.
E: Failed to fetch http://es-mirrors.evowise.com/ubuntu/dists/impish/InRelease  Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?)
N: See apt-secure(8) manpage for repository creation and user configuration details.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
E: The repository 'http://es-mirrors.evowise.com/ubuntu impish-updates InRelease' is not signed.
E: Failed to fetch http://es-mirrors.evowise.com/ubuntu/dists/impish-updates/InRelease  Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?)
E: Failed to fetch http://es-mirrors.evowise.com/ubuntu/dists/impish-backports/InRelease  Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?)
E: The repository 'http://es-mirrors.evowise.com/ubuntu impish-backports InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://es-mirrors.evowise.com/ubuntu/dists/impish-security/InRelease  Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?)
E: The repository 'http://es-mirrors.evowise.com/ubuntu impish-security InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
3

1 Answer 1

0

1. Edit netplan File

sudo vi /etc/netplan50-cloud-init.yaml

2. Add Nameserver Google / Cloudflare or any, on nameserver

network:
    ethernets:
        [network-device]:
            ...
            nameservers:
                addresses:
                - 2001:4860:4860::8888
                - 2001:4860:4860::8844
                - 8.8.8.8
                - 8.8.4.4
                - 1.1.1.1

notes: don’t use tab on this file, only space allowed.

3. Apply and Test the Network

sudo netplan apply
systemd-resolve --status

References: https://josuamarcelc.com/cannot-sudo-apt-update-failed-to-update-ubuntu/

4. After that try again

sudo apt-get update

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.