I am running an HP pavilion dv6000 dual boot win7 and Ubuntu 12.04. (well, up until today). After a reboot, the boot process drops to the BusyBox shell and I end up at the prompt:

BusyBox v1.18.5 (Ubuntu 1:1.18.5-1ubuntu4) built-in shell (ash)
Enter 'help' for a list of built-in commands.


I've been researching others who have had this same problem, but haven't been able to find any of those solutions to work for me.

I tried the method described here, and after the final command

mount -t ntfs-3g /dev/sda1 /root -o force

it does nothing and gives me another (initramfs) prompt.

I can boot to a live CD (USB) and get to a terminal, but it doesn't seem to do much good, as I can see the /dev/sda1 in the ls command, but it doesn't recognize it when I try to cd to it.

One more question: using the command fdisk -l how can I tell which mount point (sda1/sda2) is my windows partition and which one is Ubuntu?

  • 2
    This was the winner, BTW cyberciti.biz/faq/…
    – dpm
    Commented May 17, 2012 at 1:30
  • 6
    I can't believe Canonical hasn't implemented yet a proper user-friendly workflow to fix this situation :(
    – knocte
    Commented Jul 12, 2016 at 3:35
  • There has to be a better way to fix the case. You do not need Live Ubuntu for the task, since I have managed to solve it without it. I think you can fix the thing even in (inittramfs). Commented Aug 18, 2016 at 5:57
  • 4
    @Masi Actually, running fsck from initramfs fixes it in most cases now, but in the ubuntu release that was current when this question was posted, even after fsck was run, the same error was shown on boot again.
    – Amith KK
    Commented Dec 14, 2016 at 11:46
  • This very same issue happens also on Kubuntu 18.04. Whenever system suddenly freeze so I have to hard reset system; then this error occurs. I solved using with ramsudharsan's solution.
    – emre can
    Commented Nov 9, 2019 at 3:25

7 Answers 7


While at initramfs console, I passed a command exit to come out of the shell. The same console was presented before me but this time with the exact name of the partition that got corrupted.

BusyBox v1.18.5 (Ubuntu 1:1.18.5-1ubuntu4) built-in shell (ash) 
Enter 'help' for a list of built-in commands.

(initramfs) exit

/dev/mapper/ubuntu--vg-root: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY.
(i.e., without -a or -p options) 
fsck exited with status code 4. 
The root filesystem on /dev/mapper/ubuntu--vg-root requires a manual fsck. 

BusyBox v1.18.5 (Ubuntu 1:1.18.5-1ubuntu4) built-in shell (ash)
Enter 'help' for a list of built-in commands.

(initramfs) fsck /dev/mapper/ubuntu--vg-root -y

fsck from util-linux 2.27.1
e2fsck 1.42.13 (17-May-2015)
/dev/mapper/ubuntu--vg-root contains a file system with errors, check forced.

After the checking is done, I rebooted the system.

BusyBox v1.18.5 (Ubuntu 1:1.18.5-1ubuntu4) built-in shell (ash)
Enter 'help' for a list of built-in commands.

(initramfs) reboot

If reboot doesn't work, try exit.

and that's it, I got back into the filesystem without any errors.

  • 3
    the best solution! indeed saves a lot of time! especially when there's no liveusb near you.
    – OccamRazor
    Commented Feb 8, 2017 at 18:30
  • 3
    I had to reboot once to see the inconsistency error. Then I just followed this and everything was clean. Thanks!
    – niazangels
    Commented Apr 14, 2017 at 17:07
  • 15
    Worked for me. But why did it happen? Commented May 30, 2017 at 17:23
  • 3
    This worked on Ubuntu 16.04, thanks! My solution was fsck /dev/sda1 -y and it took 20 seconds (imgur.com/a/S90z5)
    – JREAM
    Commented Aug 30, 2017 at 3:13
  • 3
    @Matt Enable the keyboard option in BIOS settings (If you have disabled keyboard during boot-up, hold the power button until you hear the reset sound from the board) Commented Sep 7, 2017 at 1:52

Actually the solution is easy just write the command of fsck /dev/sdax like the below and give Y if the console ask for fixing something:

(initramfs) fsck /dev/sda1


(initramfs) fsck /dev/sdaX

X specifies mounted disk part number.

If you don't want to manually press 'y' every time it asks for a fix, you can also run the command with the -y option.

(initramfs) fsck /dev/sdaX -y
  • 4
    Get an image of the disk before doing this. It will modify the filesystem and you could lose all your files.
    – givanse
    Commented Jul 24, 2018 at 15:33
  • 2
    On my system fsck is not recognized as a command - it's not in the list of built-in commands when typing help. So it's not a fix for every time this problem occurs.
    – levitopher
    Commented Aug 29, 2018 at 14:05
  • 1
    @levitopher , what is the name of your linux distro?
    – efkan
    Commented Aug 29, 2018 at 14:59
  • 2
    @efkan: Fair comment, it's PoP!_OS by System76, but my impression is that the only difference from vanilla Ubuntu is graphics/user interface, and not in the base system. In addition, I'm tri-booting on a Mac, so obviously there are system differences, but my only comment is that contrary to the other comments, this is not a solution for everyone.
    – levitopher
    Commented Aug 29, 2018 at 16:15
  • 2
    The best and the easiest solution. But my question is why this happens. It's not that it happened onli in my system, many other have faced the same problem. But why? Commented Jul 11, 2020 at 18:26

Note: Try this answer if you continue to face the issue even after attempting the steps in @ramsudharsan's answer. If you have not tried following those instructions yet I recommend you to do so since that seems to fix the problem in most cases.

It seems that you have a bad superblock. To fix this:

Firstly, boot into a live CD or USB

Find out your partition number by using

sudo fdisk -l|grep Linux|grep -Ev 'swap'

Then, list all superblocks by using the command:

sudo dumpe2fs /dev/sda2 | grep superblock

Replace sda2 to your drive number

You should get a similar output like this

  Primary superblock at 0, Group descriptors at 1-6
  Backup superblock at 32768, Group descriptors at 32769-32774
  Backup superblock at 98304, Group descriptors at 98305-98310
  Backup superblock at 163840, Group descriptors at 163841-163846
  Backup superblock at 229376, Group descriptors at 229377-229382
  Backup superblock at 294912, Group descriptors at 294913-294918
  Backup superblock at 819200, Group descriptors at 819201-819206
  Backup superblock at 884736, Group descriptors at 884737-884742
  Backup superblock at 1605632, Group descriptors at 1605633-1605638
  Backup superblock at 2654208, Group descriptors at 2654209-2654214
  Backup superblock at 4096000, Group descriptors at 4096001-4096006
  Backup superblock at 7962624, Group descriptors at 7962625-7962630
  Backup superblock at 11239424, Group descriptors at 11239425-11239430
  Backup superblock at 20480000, Group descriptors at 20480001-20480006
  Backup superblock at 23887872, Group descriptors at 23887873-23887878

Choose an alternate superblock from this list, for this case alternate superblock # 32768

Now, to check and repair a Linux file system using alternate superblock # 32768:

sudo fsck -b 32768 /dev/sda2 -y

The -y flag is used to skip all the Fix? questions and to answer them all with a yes automatically

You should get similar output like this:

fsck 1.40.2 (12-Jul-2007)
e2fsck 1.40.2 (12-Jul-2007)
/dev/sda2 was not cleanly unmounted, check forced.
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
Free blocks count wrong for group #241 (32254, counted=32253).
Fix? yes
Free blocks count wrong for group #362 (32254, counted=32248).
Fix? yes
Free blocks count wrong for group #368 (32254, counted=27774).
Fix? yes
/dev/sda2: ***** FILE SYSTEM WAS MODIFIED *****
/dev/sda2: 59586/30539776 files (0.6% non-contiguous), 3604682/61059048 blocks

Now try mounting the partition

sudo mount /dev/sda2 /mnt

Now, try to browse the filesystem with the following commands

cd /mnt
mkdir test
ls -l
cp file /path/to/safe/location

If you are able to perform the above commands, you have most probably fixed your error.

Now, restart you computer and you should be able to boot normally.


  • 1
    I have followed all the steps for sda1 but can't do last part "mkdir test"!! There is also sda5 so I suppose to repeat steps for that?
    – Freddy
    Commented Apr 8, 2015 at 9:40
  • 2
    You write "Select an alternate superblock". Alternate to what? Can I pick any from the list? Commented Oct 27, 2015 at 11:32
  • 1
    I suggest adding to the answer, that one must answer yes to each of the "Fix questions". But also that there can be hundres of these questions, and one can answer yes for all, by using "-y" flag. Commented Oct 27, 2015 at 11:46
  • 2
    +1 for those that were using gparted and now are here Commented Aug 27, 2016 at 3:29
  • 3
    what if sudo fdisk -l|grep Linux|grep -Ev 'swap' returns 2 lines? /dev/sda2 and /dev/sda5 for me
    – knocte
    Commented Oct 2, 2016 at 8:42
  1. Simple Answer is remove your hard disk attach in another system and start the system (please don't boot from your initramfs error hard disk use any with Ubuntu and gparted installed).
  2. start gparted and select your hard disk and select CHECK from right click menu.

Slightly different answer (Ubuntu 16.04), although other answers eventually led me to it.

I first had to choose a recovery mode kernel before being able to see the error messages to know which partition/file system had errors.

From then on, running fsck /dev/sdb1/ -y fixed it for me.

  • Mention that for you, /dev/sdb1 was the partition/file system that had errors. Commented Jun 30, 2023 at 2:38

I just tried a lucky shot by booting the system with the "Parted Magic" tool from a Live CD. Looking at the partitions, there was a declared "unknown space" of some GBytes on the Linux partition.

So I just widened the Linux space over the whole Partition and voila - since then my Linux boots as before without any fail so far.


I have been dropping to busybox. The cause varies yet having a USB drive plugged in that is not the target drive makes the issue worse. Best to unplug before booting. With that drive unplugged: often a hard boot (power down and wait 10 seconds to power up) will boot correctly. For me the target drive is a SSD with a classic spinning hard drive pointing to it. My settings are a bit like this. Add a M.2 drive to Ubuntu:


Really sped up an old system. Only caveat is dropping in to busybox now and then.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .