8

I am new to Linux and I am using Ubuntu. I was use x.org drivers and I want to change to Nvidia. When I get into Software & Updates and in Additional Drivers try to change x.org to nvidia I get an error:

pk-client-error-quark:Failed to obtain authentication(303)

screenshot of error

7
  • 1
    First of all make sure your system is fully updated: sudo apt update && sudo apt full-upgrade. Nov 19, 2021 at 9:55
  • 1
    What is the Ubuntu version?
    – Pilot6
    Nov 19, 2021 at 9:59
  • 20.04 LTS is my ubuntu version Nov 19, 2021 at 10:25
  • @ChanganAuto Updating didn't work. Nov 19, 2021 at 11:02
  • Updating didn't work... So, did the update procedure produced any error or didn't but the problem persisted when trying to install the Nvidia driver? Also, are you behind a proxy? Nov 19, 2021 at 11:16

3 Answers 3

10

I had the exact same error report following a stuck update. To release the stuck update, I ran sudo apt dist-upgrade and then an autoremove.

After restarting, my screen configuration was totally trashed and the system was using the open-source non-proprietary driver (and very unstable, and slow). I tried to install the nvidia driver and received this message.

I then ran the driver installation from the command line using the following steps:

  1. identify available/appropriate drivers with this command: ubuntu-drivers devices

  2. choose the one marked "recommended"

  3. install it using the command: sudo apt install nvidia-driver-XXX (replace XXX with the driver id number you want)

  4. reboot: sudo reboot

After this, my system came back properly.

HTH

2
  • somehow, after a startup, my second screen has gone, and i did the 3rd one (sudo apt install nvidia-driver-XXX), that was solved my situation.
    – inspiron
    Feb 20, 2023 at 16:13
  • I had nvidia-driver-525 installed. I just run the command to install it again and it worked for me! Jan 5 at 6:05
4

I'm using Ubuntu 21.10 and I got the same error in "Additional Drivers". I've been flipping back and forth between different Nvidia drivers and have multiple video cards. I went into the shell and did "sudo apt autoremove" and "sudo apt install nvidia-driver-495" and the driver installed with no issue.

1
2

Upgrading to 22.10, then choosing driver 25 (recommended) in Software & updates solved my Nvidia installations issues for Nvidia RTX3080ti.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .