5

My laptop (Lenovo IdeaPad 330) has a fresh install of Ubuntu 21.10. During normal and regular use just after installation, the earphone mic was being recognised and it was functioning well. Then some time later, maybe a few weeks, the earphone mic wasn't being recognised. Pavucontrol says it is unplugged. I don't know if this is because of some update, because whenever I plug in my earphones, it brings up this prompt, which I didn't see previously.

(Please read the question till the end before flagging it as duplicate. Thank you!)

enter image description here

I click on Headset, thinking it will allow the mic to be used, but it simply doesn't. PulseAudio Volume Control still says "Headset Microphone (unplugged)". Clicking on Headphones doesn't help either.

enter image description here

Checking for microphone options under settings doesn't even list the external microphone

enter image description here

These are the details about my sound card and chip

enter image description here

Additional hardware info:

enter image description here

I'm not sure about what to do and the other questions on AskUbuntu do not match mine (they are about internal microphone or about driver issues but I do not think this is a driver problem because the external mic was working previously with no issues - but I may be wrong) or do not have any answers.

Please help.

7
  • Is the laptop headphones adapter have 2 ports at once (microphone and headphones port)? If simply pressing the headset button still doesn't work, try downgrading to Ubuntu 20.04 LTS, Ubuntu 21.04 has not been recommended to upgrade. Nov 26, 2021 at 9:03
  • It sounds / looks to me like you have a rogue audio package / program that has a hold of your sound card. When your system boots, it is a first-come-first-serve situation. There are only so many io devices, and if you install (or misconfigure) the wrong app, it will grab on before alsa has a chance to do so. When this happens, the device node won't even show up in the lspci output, but will show up in other listings (which, going by the output you've posted, seems to be the case here.)
    – Nate T
    Nov 27, 2021 at 7:37
  • If you can remember the date (or close to it) when you first experienced the issue, check your install logs for any audio apps installed just before. Changes do not take effect until reboot, so take that into account. Instead of uninstalling anything straight away, try killing the running processes for a suspect first, to test.
    – Nate T
    Nov 27, 2021 at 7:39
  • I have managed to solve this issue using askubuntu.com/a/1233446/683535. This did not work for me but I realised I had followed the answer incorrectly. I retried this solution by chance and it worked. Thank you for your responses and your time
    – Devvrath
    Nov 27, 2021 at 8:59
  • 1
    @Martian2020 I have done so
    – Devvrath
    Dec 1, 2021 at 8:23

1 Answer 1

2

This issue can be resolved by following these steps:

  1. Find out your machine's codecs with cat /proc/asound/card*/codec* | grep Codec
  2. In my case I saw Codec: Realtek ALC236 Codec: Intel Kabylake HDMI.
  3. Go to www.kernel.org and lookup your codec. In my case it was Realtek ALC23x
  4. I chose dell-headset-multi as the other codec options did not work for me.
  5. Add the line options snd-hda-intel model=dell-headset-multi in the alsa-base.conf file by opening the file with the command sudo gedit /etc/modprobe.d/alsa-base.conf and edit it.
  6. Save and close the file. Reboot your system for the changes to take effect.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.