0

I am switching several Computers from Windows to Ubuntu 20.04 and have a problem with a very, very old SMB Server i have to connect to. That Server is running Samba V2.2.5 and is configured to use ISO8859-15 as a charset for all files and drives on this server. I cannot change the configuration of that server because several windows clients are connecting to it.

After several days of try&error i managed to mount that SMB share on my Ubuntu 20.04 client with the following command:

sudo smbmount //192.168.224.16/jw /mnt -o username=jw,sec=ntlm,vers=1.0,uid=1000,gid=1000,nounix

Yes, i know sec=ntlm is really, really obsolete, and yes, i know vers=1.0 is really, really obsolete, too. Nevertheless this is the only protocol combination i found out to work connecting to this ancient server.

The only problem left is the conversion of german Umlauts in Filenames. If i ls a directory on that server it looks like:

drwxr-xr-x 2 jochen jochen 0 Mai 10  2015  .
drwxr-xr-x 2 jochen jochen 0 Sep 30 16:32  ..
drwxr-xr-x 2 jochen jochen 0 Jul  1  2020  W007D_Dokumente
drwxr-xr-x 2 jochen jochen 0 Mär 21  2020  W007L_Leiterplatten
drwxr-xr-x 2 jochen jochen 0 Feb 19  2015  W007S_Software
drwxr-xr-x 2 jochen jochen 0 Mär 21  2020 'W007Z_Zusammenf'$'\201''gungen'

The last directory should be "W007Z_Zusammenfügungen". I tried several "iocharset="-Options when mounting - no difference at all. I tried "codepage="-Options when mounting - seems to be obsolete and not used any longer.

locale on the Ubuntu client shows:

jochen@HP8510W-3:~$ locale
LANG=de_DE.UTF-8
LANGUAGE=de_DE:en
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC=de_DE.UTF-8
LC_TIME=de_DE.UTF-8
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY=de_DE.UTF-8
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER=de_DE.UTF-8
LC_NAME=de_DE.UTF-8
LC_ADDRESS=de_DE.UTF-8
LC_TELEPHONE=de_DE.UTF-8
LC_MEASUREMENT=de_DE.UTF-8
LC_IDENTIFICATION=de_DE.UTF-8
LC_ALL=

Any ideas?

Thankful for all support i can get!

1 Answer 1

0

Some experimenting:

~/test$ touch W007Z_Zusammenfügungen
~/test$ convmv -f UTF-8 -t ISO_8859-15 W007Z_Zusammenfügungen --notest
~/test$ ls
'W007Z_Zusammenf'$'\374''gungen'

(I got '$'\374'' to represent ü, not '$'\201''.)

Then I took these steps:

  1. Created the German ISO-8859-1 locale:

    ~/test$ sudo locale-gen de_DE
    Generating locales (this might take a while)...
      de_DE.ISO-8859-1... done
    Generation complete.
    
  2. Changed the encoding in my gnome-terminal profile to Western — ISO-8859-15

And then:

~/test$ LC_CTYPE=de_DE ls
W007Z_Zusammenfügungen

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.