Possible Duplicate:
Can I skip over releases?

I tried to upgrade from 11.04 to 12.04 by Update manager, but failed.

The error message was:

Failed to fetch http://kr.archive.ubuntu.com/ubuntu/pool/main/t/ttf-alee/ttf-alee_12+nmu1ubuntu1_all.deb'

How can I fix it?

marked as duplicate by Jorge Castro, hhlp, belacqua, Alvar, fossfreedom May 18 '12 at 19:52

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Can the person that down voted please add a comment. Thank you. – Switchkick May 15 '12 at 21:44
  • 1
    @Ants You mustn't add a comment after a down vote. it's optional. – Alvar May 15 '12 at 21:45
  • 3
    I think if you add a comment it helps the user to refine their question next time. Simply down voting doesn't let the user know what they've done wrong. – Switchkick May 15 '12 at 21:49
  • @SanghyukJung If you say 11.04 and mean 11.10 you really deserve a down vote. – Alvar May 17 '12 at 6:36

You can't upgrade from 11.04 to 12.04. You must upgrade to 11.10 and then to 12.04. You can only skip upgrades if you upgrade from an LTS (10.04) to a LTS (12.04). You can't skip in-between.

I suggest you download an 11.10 image from here. And then upgrades via a usb-stick (live-cd). and then upgrades to 12.04, via the same method.

  • I tried, but got same result. – Sanghyuk Jung May 16 '12 at 11:47
  • @SanghyukJung what did you try? what exactly did you do? :) – Alvar May 16 '12 at 15:56
  • Why fresh install 11.10 only to upgrade?? Just do a fresh install of 12.04. – amc May 16 '12 at 16:27
  • 1
    @amc it's not a fresh install it's an upgrade via live-cd! – Alvar May 16 '12 at 16:47
  • But i think when you use a live cd you can upgrade from 11.04 to 12.04 directly!! The online upgrade needs 11.10! Just confirm once...! – Nirmik May 16 '12 at 17:31

I fixed it.

I guess there was a temporarily problem in accessing http://kr.archive.ubuntu.com/ubuntu/pool/main/t/ttf-alee/ttf-alee_12+nmu1ubuntu1_all.deb

I downloaded 'ttf-alee_12+nmu1ubuntu1_all.deb' from a mirror site and install it manually, then completed the online update.

But now 'ttf-alee_12+nmu1ubuntu1_all.deb' is available on 'kr.archive.ubuntu.com'. I guess there is no problem now.

Thank you for all comments.

  • you said it was 11.04 to 12.04, which you can't do. But now you say it was 11.10 to 12.04! it's impossible to help you if you don't give us the correct information. – Alvar May 17 '12 at 16:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.