1

I'm setting up Xubuntu (so I'm using the default Desktop Environment xfce) and just changed my default terminal to alacritty by modifying the terminal utility in the "Default Applications" tool.

That worked fine apart from one thing: When I start Alacritty for example from desktop right-click "Open Terminal here", it's started with working directory set to ~/Desktop, I would like for this to be just ~ instead. How do I achieve this?

I tried to modify the application string from /usr/bin/alacritty "%s" to /usr/bin/alacritty --working-directory=/home/moberg "%s" but it doesn't seem to have any effect, it still starts up with ~/Desktop as cwd.

I don't want to set the alacritty configuration working_directory because when I open new terminal windows from elsewhere I would like for them to keep the current working directory.

2
  • 1
    Open Terminal here should open your terminal in your current directory. Are you selecting this option from within your Downloads directory? If so, this is the intended behavior. Nov 15, 2021 at 11:28
  • 1
    Oh I'm stupid. Thanks! It was actually working, it's opening in ~/Desktop (not Download as I incorrectly wrote). I just didn't realize it was "open here" even though the button says so >.>
    – Moberg
    Nov 15, 2021 at 12:17

1 Answer 1

1

"Open Terminal Here" will open the terminal at the current folder, so if you right click on the desktop it will open in ~/Desktop.

If you open it from the applications menu (top right in xfce) it will start in your selected working directory: ~.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.