I've tried to set up a VPN server on my copy of Ubuntu 10.10 with insuccess. Community material on the topic is little and poorly documented (clients only information, scenario-specific information, WIP pages, ...)

What I need in specific is tunnelling of traffic over HTTPS to go around a proxy server that only allows HTTP and HTTPS protocols.

What I did try is following this ubuntugeek.com guide. I've gone through each step (here are my config files), set up an account through DynDns.com, set up port forwarding and set up a VPN on my copy of Windows 7:

  • Endpoint: redacted
  • Username: badp (I also tried delta)
  • Password: redacted

I've also turned on logging on the Windows 7 side of things and attempted to connect from an unfiltered location. From the logs, it seems like the connection is dropped right after authentication takes place.

Where did I go wrong? Was there a guide on the Ubuntu official resources I could've tried instead?

| improve this question | | | | |
  • Obviously, by the best of my knowledge, the redacted bits are accurate. – badp Nov 17 '10 at 23:55
  • List the contents of firewall tables is pretty helpful for solving your question.Just add the sudo iptables -t filter -L and sudo iptables -t nat -L results to above description. – kit.yang Nov 18 '10 at 1:43
  • @kit.yang Here you are, it's pretty uneventful. – badp Nov 18 '10 at 8:22

Why not just use OpenVPN? It's very easy both on Windows and Linux.

| improve this answer | | | | |
  • 1
    Sure, but how would I do that? :) – badp Nov 18 '10 at 8:11

Here's a straightforward guide: http://rootmanager.com/ubuntu-ipsec-l2tp-windows-domain-auth/setting-up-openswan-xl2tpd-with-native-windows-clients.html but it doesn't cover tunneling it over http/https

another solution is here: http://www.exiledmind.net/vpn-tunnel/ this maps EXACTLY to what you are trying to do.

I prefer openswan since openvpn is client number limited now

if the auth is succeeding but the tunnel isn't formed this usually means the two end-points can't agree on tunnel mode and/or crypto system. another possibility is a routing problem where the near and far networks are on the same private subnet and your traffic gets dropped because it doesn't know to transit the vpn link.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.