6

I'm using Ubuntu 12.04 on a Thinkpad X200. To configure the trackpoint, I use "configure TrackPoint". Unfortunately I can't make Ubuntu saving my settings (concerning the sensitivity etc.). Whenever I reboot the computer, it's set to generic settings again.

I already tried htorque's answer to a similar question and created a new udev-rule for the trackpoint-settings but it didn't helped.

So, how can I make theses settings permanent?

7

I finally found a working solution:

1. Find the device path of your trackpoint

Run the following in a gnome-terminal (can be opened with Ctrl+Alt+t):

find /sys/devices/platform/i8042 -name name | xargs grep -Fl TrackPoint | sed 's/\/input\/input[0-9]*\/name$//'

It will return something like

/sys/devices/platform/i8042/serio1/serio2

change to whatever it returns for you in the following step.

2. Create a new upstart-job

Still in the terminal type:

sudo gedit /etc/init/trackpoint.conf

A text editor will pop up. Paste the following code in it:

description "Trackpoint-Settings"
env TPDIR=/sys/devices/platform/i8042/serio1/serio2
start on virtual-filesystems
script
  while [ ! -f $TPDIR/sensitivity ]; do
        sleep 2
  done
  echo -n 200 > $TPDIR/sensitivity
  echo -n 150 > $TPDIR/speed
  echo -n 1 > $TPDIR/press_to_select
end script

Don' forget to edit the second line if needed (see step 1).

You can edit the numbers in line eight and nine (representing sensitivity and speed) to whatever you prefer. Both can be set in a range from 0 to 255. Leaving them at 200 and 150 works good for me.

Save and exit.

That's it.

  • To anyone who happens on this from a later version of ubuntu which is using systemd instead of upstart, there is info here: askubuntu.com/questions/596085/… Again, be sure to adjust the device path accordingly. – waffl Aug 15 '18 at 8:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.