1

I am having an issue with VMWare on Linux.After trying to launch an Ubuntu or Windows Guest on a host running Ubuntu 20.04 LTS 64-BIT, I am presented with the following three errors:

Could not open /dev/vmmon: No such file or directory. Please make sure that the kernel module ‘vmmon' is loaded.

After clicking OK, the 2nd error:

Failed to initialize monitor device.

After clicking OK on the 2nd error, the 3rd error:

Unable to change virtual machine power state: Transport (VMDB) error -14: Pipe connection has been broken

Host Info: AMD 64-Bit FX9800 8-core CPU, 32GB Ram, plenty HDD Space. OS: Ubuntu 20.04 LTS running latest kernel 5.11.0-40-generic. VMware Workstation Pro 16.2.1 (build 18811642). UEFI - Secure Boot Enabled. Single Boot Only - No Windows Partition.

Guest Info: Both Ubuntu and Windows guests are set to boot via BIOS and not UEFI. I tried creating a new VM using UEFI and the same issue occurred.

Steps I have so far taken:

  • Uninstalled via terminal command sudo vmware-installer -u vmware-workstation, rebooting, then re-installing via sudo sh VMware-Workstation-Full-16.2.1-18811642.x86_64.bundle (installed via CLI - did not use GUI installer). I then rebooted, same issue. Both with previous VM and brand new VM.

  • Physically at host machine, uninstalled via terminal command sudo vmware-installer -u vmware-workstation, rebooting, then re-installing via sudo sh VMware-Workstation-Full-16.2.1-18811642.x86_64.bundle. I then rebooted, same issue. Both with previous VM and brand new VM.

  • Confirmed dkms is installed and all updates are installed. Installed packages linux-tools-generic-hwe-20.04, libelf-dev, linux-generic, fdutils, then uninstalled VMWare, rebooted and re-installed VMware. Same issue when launching guest VMs.

  • Tried generating SSH keys as per https://kb.vmware.com/s/article/2146460:

    $ openssl req -new -x509 -newkey rsa:2048 -keyout MOK.priv -outform DER -out MOK.der -nodes -days 36500 -subj "/CN=VMware/"
    $ sudo /usr/src/linux-headers-`uname -r`/scripts/sign-file sha256 ./MOK.priv ./MOK.der $(modinfo -n vmmon)
    $ sudo /usr/src/linux-headers-`uname -r`/scripts/sign-file sha256 ./MOK.priv ./MOK.der $(modinfo -n vmnet)
    $ mokutil --import MOK.der
    
  • Signed the modules using sudo /usr/src/kernels/$(uname -r)/scripts/sign-file sha256 ./MOK.priv ./MOK.der $(modinfo -n vmmon) and sudo /usr/src/kernels/$(uname -r)/scripts/sign-file sha256 ./MOK.priv ./MOK.der $(modinfo -n vmnet)

  • Rebooted. Issue persists.

  • Tried running sudo vmware-modconfig --console --install-all. Output will be located at https://paste-bin.xyz/12577

    The last section showed:

    Starting VMware services:
    Virtual machine monitor   failed
    Virtual machine communication interface   done
    VM communication interface socket family   done
    Virtual ethernet   failed
    VMware Authentication Daemon   done
    

What else should I try? How can I fix this?

4
  • Have you confirmed that AMD-V (virtualisation) is enabled in the UEFI? Just to be clear, the host is running Ubuntu Desktop, yes? 🤔
    – matigo
    Nov 13, 2021 at 12:59
  • @matigo Virtualization is enabled. Yes, desktop Ubuntu. 20.04 LTS. Nov 14, 2021 at 6:59
  • Disabled secure boot: sudo mokutil --sb-state SecureBoot disabled But getting the same result: Starting VMware services: Virtual machine monitor failed Virtual machine communication interface done VM communication interface socket family done Virtual ethernet failed VMware Authentication Daemon done Kernel version: 5.11.0-40-generic Vmware version: VMware Workstation 16.2.1 build-18811642
    – Jeroen
    Nov 26, 2021 at 9:02
  • So I just solved this issue today after trying a ton of different things but I think the VMware KB you linked was the final piece. So if you run through this process and then enroll the modules into secureboot it should work. communities.vmware.com/t5/VMware-Workstation-Pro/… Feb 19 at 21:33

1 Answer 1

0

There is one possibility I should point out, and that is either your internet is the cause or incorrect configuration on the VM.

Virtual machine monitor failed / Virtual ethernet failed

Disable secure boot via BIOS.The likely reason that's showing is that the verification checks on modern operating systems, conflicts with VMware algorithms, therefore giving those errors.

After you rebooted the host machine, with secure boot OFF, drop to shell and re-execute the command you tried:

vmware-modconfig --console --install-all

If this text appears:

list of VM services in terminal

It should take care of it. Just note that VMs are not the same as dual-boot. Almost all editing of the VM requires action from the host machine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.