1

I'm attempting to dual boot Kubuntu 21.10 on my desktop on a separate drive from my windows 10 drive. I have followed several tutorials for creating a bootable flash drive and just going through the installer. I don't seem to have any problems until I remove the media and restart. Grub comes up right away and I can boot into windows no problem. But if I select ubuntu I don't even get the kubuntu startup image I just see the ROG motherboard brand logo and the system freezes. My system is a UEFI boot system with an AMD cpu so it's not an issue with things like intel rapid storage tech requiring a shift to AHCI sata protocols. When partitioning my install I have attempted to setup a root, swap, and boot partition as well as putting the bootloader on the same EFI partition that the windows bootloader is installed on. I have also tried placing an EFI partition instead of a /boot partition with the other partitions remaining the same and the bootloader location the same as before. Nothing seems to be working. I will be attempting 20.04 version to see if this problem persists. Any advice for how to troubleshoot this would be greatly appreciated.

Edit: Have attempted 20.04 with the exact same result. I will continue to investigate further.

Edit 2: I can boot in if I use the advanced options to boot in recovery mode. I have run checks on packages with no issues found. On reboot in recovery mode the system indicated there were certain graphical settings that would not be enabled unless a reboot was performed. Still not certain what the solution would be. Still cannot boot normally at all. If any terminal commands can be utilized to narrow the problem down further it would be greatly appreciated.

2
  • 2
    Does the installer include a "Try Kubuntu" option? If so, boot into it. Does that work properly? Does your hardware (disk, network, monitor, keyboard, mouse, printer, etc) work properly in that environment?
    – user535733
    Nov 13, 2021 at 3:58
  • 1
    Yes that seems to work just fine. I have also attempted 20.04 with the exact same result.
    – jajone4
    Nov 13, 2021 at 4:07

1 Answer 1

2

Ok so the solution was not to install the 3rd party drivers as well as the nvidia proprietary ones. So yes this was a graphical issue. The driver update was handled by opening up the terminal and typing:

ubuntu-drivers devices

followed by:

sudo ubuntu-drivers autoinstall

I selected the 495 proprietary drivers this time as the 470 drivers seemed to be what was causing the issue and then typed:

sudo apt install nvidia-driver-495

Following this I rebooted and the issue was resolved.

1
  • OK... Please, remember to update your answer with the procedure you'll safely update your drivers with. That's just for a better-quality answer. Nov 13, 2021 at 14:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.