-1

after i added an mSATA i have the problem, that my Acer SF114-34 would not go to standby. before it worked perfectly...

I already

  • Manipulate /etc/systemd/logind.conf HandleSuspendKey=suspend HandleLidSwitch=suspend HandleLidSwitchDocked=suspend
  • Already activated "suspend after closed lid" in Gnome-Tweak-Tool
  • In Bios S3 is active. I never change these setting.
  • The new mSATA is encrypted with Luks

Command: journalctl| grep suspend

Nov 08 17:20:57 cthulhu systemd[1]: systemd-suspend.service: Succeeded. Nov 08 17:22:55 cthulhu ModemManager[1079]: [sleep-monitor] system is about to suspend Nov 08 17:23:00 cthulhu kernel: PM: suspend entry (deep) Nov 08 17:23:02 cthulhu kernel: printk: Suspending console(s) (use no_console_suspend to debug) Nov 08 17:23:03 cthulhu kernel: PM: suspend exit Nov 08 17:23:03 cthulhu systemd[1]: systemd-suspend.service: Succeeded. Nov 08 18:41:28 cthulhu ModemManager[1066]: [sleep-monitor] system is about to suspend Nov 08 18:41:33 cthulhu kernel: PM: suspend entry (deep) Nov 08 18:41:35 cthulhu kernel: printk: Suspending console(s) (use no_console_suspend to debug) Nov 08 18:41:36 cthulhu kernel: PM: suspend exit Nov 08 18:41:36 cthulhu systemd[1]: systemd-suspend.service: Succeeded. Nov 08 18:47:31 cthulhu systemd-logind[1005]: Requested hibernate operation is not supported, using regular suspend instead. Nov 08 18:47:31 cthulhu ModemManager[1066]: [sleep-monitor] system is about to suspend Nov 08 18:47:31 cthulhu systemd-logind[1005]: Requested hibernate operation is not supported, using regular suspend instead. Nov 08 18:47:31 cthulhu systemd-logind[1005]: Requested hibernate operation is not supported, using regular suspend instead. Nov 08 18:47:31 cthulhu systemd-logind[1005]: Requested hibernate operation is not supported, using regular suspend instead. Nov 08 18:47:31 cthulhu systemd-logind[1005]: Requested hibernate operation is not supported, using regular suspend instead. Nov 08 18:47:31 cthulhu systemd-logind[1005]: Requested hibernate operation is not supported, using regular suspend instead. Nov 08 18:47:31 cthulhu systemd-logind[1005]: Requested hibernate operation is not supported, using regular suspend instead. Nov 08 18:47:31 cthulhu systemd-logind[1005]: Requested hibernate operation is not supported, using regular suspend instead. Nov 08 18:47:31 cthulhu systemd-logind[1005]: Requested hibernate operation is not supported, using regular suspend instead. Nov 08 18:47:31 cthulhu systemd-logind[1005]: Requested hibernate operation is not supported, using regular suspend instead. Nov 08 18:47:36 cthulhu kernel: PM: suspend entry (deep) Nov 08 18:47:38 cthulhu kernel: printk: Suspending console(s) (use no_console_suspend to debug) Nov 08 18:47:39 cthulhu kernel: PM: suspend exit Nov 08 18:47:39 cthulhu systemd[1]: systemd-suspend.service: Succeeded.

Do you have any idea to fix that? Thank's and Greetings

0

2 Answers 2

0

I was able to find out the error. The problem was that the new mssd I had installed did not go into sleep mode. As a workaround this helped me -> Ubuntu wakes up after few seconds of sleep

1
  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review
    – Tom
    Jun 12 at 1:46
0

Here is the answer from the link (Ubuntu wakes up after few seconds of sleep) packaged as a quote. This serves as a copy.

Check the wakeup events for your PC:

2& [romano:~/etc] % cat /proc/acpi/wakeup 
Device  S-state   Status   Sysfs node
PCI0      S4    *disabled  no-bus:pci0000:00
COM1      S4    *disabled  pnp:00:06
PEGH      S4    *disabled
PEGL      S4    *disabled
IGBE      S4    *enabled   pci:0000:00:19.0
PCX1      S4    *disabled  pci:0000:00:1c.0
PCX5      S4    *disabled  pci:0000:00:1c.4
PCX7      S4    *disabled  pci:0000:00:1c.6
HUB       S4    *disabled  pci:0000:00:1e.0
EUS1      S3    *enabled   pci:0000:00:1d.0
EUS2      S3    *enabled   pci:0000:00:1a.0
PBTN      S4    *enabled

The enabled events are the one that can wake up your computer. One of these is firing up in your case; you have to discover which one.

You can toggle the wakeup status on, for example, EUS1 (whatever it means --- no idea) with the command:

echo EUS1 | sudo tee /proc/acpi/wakeup

and then you can check that the wakeup is disabled, by repeating the first command. Now you can try to suspend and see if the PC stays suspended or not. Repeat.

Do not disable the event on PBTN --- it is the power button. You can be unable to resume in that case!

My strategy is normally to disable everything minus the PBTN --- now the resume should be trigger only with the power button. You can then try to reenable other sources (or not).

Once you have found the culprit(s) event(s), you can add them to your /etc/rc.local to make the change permanent. Notice however that the interface is really badly thought, and you can only toggle the status of enabled/disabled, not set it; so for example to disable the EUS1 independently on its status you should use

grep 'EUS1.*enabled' < /proc/acpi/wakeup >/dev/null && echo "EUS1" > /proc/acpi/wakeup

in your /etc/rc.local.

In my case the culprit where EHC y XHC devices, probably because I have an USB keyboard (not sure though), this is en excerpt of my rc.local:

for device in XHC EHC1 EHC2; do
    grep $device /proc/acpi/wakeup | grep enabled > /dev/null && {
        echo Disabling wakeup on $device 
        echo $device > /proc/acpi/wakeup
    }
done

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.