My volume keys are not working in xfce. When I used them it shows an indication on the screen that the volume is being changed, but the volume is not changing at all (same thing with the mute key).

The weird thing is that when I go from xfce to ubuntu the keys are now working fine.

I don't know if this matters but I have a sound card in my computer.

How can I make the volume keys work in xfce?

  • Do you have other sound devices activated such as HDMI? Perhaps the volume keys are configured to these devices rather than your primary speaker. Try go to the volume control (or type pavucontrol in terminal) and look under configuration for other devices. Turn any other devices off than your built-in audio and log out to see the changes. Commented May 15, 2012 at 17:56

9 Answers 9


This is still broken in 12.10. You can fix it by installing xfce4-mixer and then manually selecting the mixers to control with it - and then going into the xfce4 settings editor and typing in the name of the "active card". The mute button still won't work properly, you can mute but not unmute the sound with it. Everything else works though, including on screen notifications. It's really tricky to get it all working, so I opened a bug: https://bugs.launchpad.net/ubuntu/+source/xfce4-mixer/+bug/1085752

In detail, in xfce4-mixer you want it to look something like this:


This should show only the primary volume control of your sound card. You have to choose a sound card at the top and then click "Select Controls..." to add controls. Then in the xfce4-settings-editor you need to set the "active-card" like this:


Under "sound-cards" you'll see a list of every sound card for which you added mixers. You will probably have multiple cards so it might take some trial and error here to find the right one. You need to copy the name of the correct card from "sound-cards" to "active-card" - this will be the mixer which the volume buttons control.

  • I managed to find a card that I could control with volume up, volume down, and mute - but not unmute. I had to instead use a different card for unmute to work; I was able to figure out which card to use by finding the one all of the controls worked in the xfce4-mixer app (and not having to go through the entire process of adding the card and testing my keyboard shortcuts every time).
    – corvec
    Commented Apr 2, 2013 at 14:44
  • 2
    For some reason "active-card" is not listed under "Property" for me.
    – user87317
    Commented Feb 14, 2014 at 18:08
  • @user87317 I have the same problem, you need to copy it from 'sound-card' property value. it is a simple string.
    – logoff
    Commented Mar 15, 2014 at 15:29

xfce4-volumed only works for me when it is not running in daemon mode. The volume keys work for me when I run this command to kill any existing volumed processes and start a new one that is not running in daemon mode:

kill `pidof xfce4-volumed` ; mkdir -p /tmp/volumed && cd /tmp/volumed && nohup xfce4-volumed --no-daemon &

This runs the process using nohup, so the terminal in which you run this command can be closed without killing the process.

  • 2
    Ah, well there's my problem! - either xfce4-volumed died, or it's not starting on login (it's been too long since I rebooted that I don't recall if I had the problem the last time I booted). Manually starting xfce4-volumed did the trick for me (works fine in daemon mode, too). Commented Nov 17, 2014 at 8:20
  • Hey! Progress! so far I am just running xfce4-volumed --no-daemon directly in a terminal, now I just have to figure out how to get it to start-up when I boot up!
    – nmz787
    Commented Jan 6, 2015 at 3:28

Those volume keys are gnome based... Or unity based or whatever... You have to create a custom keyboard shortcuts in the keyboard settings gui to reduce, increase and mute volume... For volume increase, the command is "amixer set master 5%+" for volume decrease "amixer set master 5%-" for mute "amixer set master toggle"

  • This works, but it doesnt provide the notify-osd which comes with xfce4-volumed.. so there's no on screen feedback at all...
    – kolslorr
    Commented Nov 6, 2012 at 7:45

I had the same problem in Xubuntu 12.04, though I don't know if it would have worked in Unity, since I only have Xfce4. In terminal, type:

$ xfconf-query -c xfce4-mixer -p /active-card -s xfconf-query -c xfce4-mixer -p /sound-card

Source: https://wiki.archlinux.org/index.php/Xfce#Xfce4-volumed

  • This won't work in 12.10 because xfce4-mixer isn't installed by default and so those settings won't exist. See my answer below for how to create them. Commented Dec 3, 2012 at 0:37

If this is a temporary problem, like it was in my case, just do it in command line:

killall xfce4-volumed && xfce4-volumed


I fixed the problem changing the "Active Card" parameter in the xfce4-settings-editor

I have two sound card (one HDMI and the other a normal one) and the selected card was different from the normal card that I was using.


I had this very odd problem as well, I could adjust the volume slider in the menu and it would do nothing. Also, if I tried adjusting it with my keyboard, the slider would move but nothing would change with the actual volume.

I fixed it by going to PulseAudio Volumne Control. In the Output Devices panel, you can see all of your sound card options. From there, I made sure the port was set to Analog Output. In your case it might be HDMI or headphones depending on where you want your sound to go. Then select the 'set as fallback option'. It looks like a green check mark.

I didn't have to install xfce4-mixer to get this to work.


In Settings > Settings Manager > Keyboard > Applications Shortcut:

  • add amixer set Master 3+ to increase volume
  • add amixer set Master 3- to decrease volume
  • add amixer -D pulse set Master Playback Switch toggle to mute/unmute sound

I met similar problem, and managed to solved it.

I realize in my Ubuntu Studio 18.10 XFCE4, the startup application included XFCE Volume Daemon, which when I disabled it, reboot, and installed xfce4-pulseaudio-plugin, it'll then works as intended.

Hope it helps others out there.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .