0

I have two hard drives. First with Ubuntu. Second, where I just installed ClearLinux. But GRUB doesn’t display the boot menu and immediately boots Ubuntu.

Some information:

➜  ~ lsblk -l | grep -v snap
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
loop29   7:29   0 310,8M  1 loop 
sda      8:0    0 232,9G  0 disk 
sda1     8:1    0   149M  0 part 
sda2     8:2    0 232,8G  0 part 
sdb      8:16   0 111,8G  0 disk 
sdb1     8:17   0 111,8G  0 part /
sr0     11:0    1  1024M  0 rom
➜  ~ sudo update-grub                                                                                                         
Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/init-select.cfg'
Création du fichier de configuration GRUB…
Image Linux trouvée : /boot/vmlinuz-5.4.0-89-generic
Image mémoire initiale trouvée : /boot/initrd.img-5.4.0-89-generic
Image Linux trouvée : /boot/vmlinuz-5.4.0-88-generic
Image mémoire initiale trouvée : /boot/initrd.img-5.4.0-88-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Clear Linux OS trouvé sur /dev/sda2
fait

and :

➜  ~ cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

How to configure GRUB to display boot menu ? Other answers atlk about a GRUB_HIDDEN_TIMEOUT. But it is not in grub config file.

Note : I see talking about EFI, but I don't know very about UEFI/EFI ...

Edit : By pressing Shift at computer boot, i can display the grub boot menu. But Grub list only display Ubuntu !

Thanks !

3
  • So add GRUB_HIDDEN_TIMEOUT if it is not there. and don't forget to update grub.
    – Pilot6
    Nov 6, 2021 at 10:45
  • Hello @Pilot6 , according to documentation, this parameter is not relevant for me :(
    – bux
    Nov 6, 2021 at 12:00
  • In my 20.04 it is used. I didn't change it.
    – Pilot6
    Nov 6, 2021 at 14:28

1 Answer 1

0

GRUB_HIDDEN_TIMEOUT is used for an older version of grub.

Change

GRUB_TIMEOUT_STYLE=hidden

to

GRUB_TIMEOUT_STYLE=menu

and then run update-grub

This does the same thing that commenting out GRUB_HIDDEN_TIMEOUT in older versions of grub did.

4
  • It's working ! Thanks
    – bux
    Nov 6, 2021 at 13:20
  • Both ways work.
    – Pilot6
    Nov 6, 2021 at 14:28
  • What do you mean by "older version of grub". I read the latest doc and hidden is still there.
    – Pilot6
    Nov 6, 2021 at 15:09
  • The default config file has changed because newer better options are available.
    – user10489
    Nov 9, 2021 at 12:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.