For example there is no logout button:

Screenshot user menu

If I log in with the guest session, everything seems to be fine (there is a log out button). I tried to remove my whole user directory and create an empty one, but the problem remains.

I am running Gnome Shell 3.4 using the PPAs ppa:gnome3-team/gnome3 and ppa:ricotz/testing as described in this answer. I disabled all shell extensions and restarted the computer, but the problem remains.

Another difference between my user and the guest user I noticed: when I close the last window on the current workspace, the activitiy overview appears. This annoying beheviour seems to be disabled for the guest user.

I'm thinking to switch to Debian. I try to get 12.04 running with Gnome Shell since 2 days now...

  • Why did you use those repositories? You shouldn't need them in 12.04 – jplatte May 16 '12 at 6:40
  • @jP_wanN The linked answer says "a lot of the 3.4 packages will be installed by default minus a few that will be kept at 3.2 for stability reasons". Well, yeah, that does not say that it is a good idea to use these packages, but with 3.2 the extensions weren't working well. – lumbric May 16 '12 at 14:44
  • I installed it through the official repositories and it works perfectly. You should always try the stable packages from the official repositorys first. Try removing the ppas with ppa-purge and reinstalling gnome-shell through the official repositories. – jplatte May 17 '12 at 9:32
  • @jP_wanN Ok, I'll try to do that - thanks! Maybe I'll just give it a another try with a fresh installation. Actually I think I was wrong when I though I'd need the new gnome shell version 3.4. – lumbric May 17 '12 at 9:39

A reinstall (with the same home directory) without the mentioned repositories solved the problem. I don't know why I thought I'd need newer versions.

| improve this answer | |

Did you try creating a new user account and selectively moving your files from the old account in to the new one? If not, try that. Let me know how it goes!

| improve this answer | |
  • I did not want to mess up my passwd file and get in trouble with different UIDs, but thanks for your help! – lumbric May 17 '12 at 11:54

Hi i used too the ricotz gnome shell ppa, i use synapse launcher to log out session, because the new versions not comming with this option yet. synapse works to logout. i don' t miss log out option in user menu. ( sorry my bad english :P )

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.