0

I'm trying to install Ubuntu on a Dell Latitude 5490. Ubuntu will be the only OS I use on this computer

Steps I've taken:

  • Used Rufus to put DBAN on a flash drive and autonuke C: drive
  • Used Rufus to put ubuntu-20.04.3-desktop-amd64.iso on a flash drive
  • Booted from flash drive, Try Ubuntu works well
  • Installed Ubuntu, appeared to succeed
  • Upon restart, computer shows "No bootable devices found"
  • Dell Diagnostics indicates all hardware is working correctly/found
  • Enabled Secure Boot, and attempted to define a UEFI Boot Option for Boot Sequence. The EFI Boot Selection screen for selecting a file shows :FSO but is otherwise blank. When I manually enter the file \EFI\ubuntu\grubx64.efi, I still get the "No bootable devices found" screen (disabling Secure Boot and booting from Legacy Option ROMs also failed)
  • I tried running boot-repair from Try Ubuntu, which I saw in another post. It ran successfully but still same error upon restart
  • I reinstalled Ubuntu from flash drive, and it does see that Ubuntu is already installed. I re-did the installation anyway but still same issue

I feel like I'm running out of ideas on what to try next and would love any advice. Thank you!

4
  • Try it in UEFI with secure boot disabled, then you must be able to start grub
    – lucki1000
    Nov 4, 2021 at 7:09
  • @lucki1000 what File Name or Boot Option should I use? I am trying now with Secure Boot disabled, Legacy Option ROMs disabled, and using UEFI Boot Option with File System List PCiRoot(0x0)/Pci(0x17.0x0)/Sata(0x2.0x0)/HD(1.MBR.0x81A3237C) and File Name: \EFI\ubuntu\grubx64.efi. Still not working though. Thank you! Nov 4, 2021 at 11:31
  • 1
    You are using MBR, on your HD you must change your partition table of your HD, means you start gparted, select your install disk, go to the tab with the label device and click create partition table, then you have to select GPT after that you can boot up your PC
    – lucki1000
    Nov 8, 2021 at 4:20
  • Sorry to put a comment in the answer section, I dont have enough reputation for comment. Did you manage to resolve the issue? I am in the same boat, i am install it on Dell vostro 470. It has a built in RAID, I am not sure if it is causing any issue.
    – skb007
    Feb 8 at 23:39

1 Answer 1

-1

I had/have the same problem. I found that if I tap F12 to get the boot menu, it shows my M.2 SSD drive as an option. If I select that, it boots every time. I have no idea why this works, as I've never seen this behavior before.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.