I am trying to add a CUPS printer via settings/printers. After clicking "Add..." the printer isn't listed until hostname is given. Then selecting the printer results in this error: "Failed to add new printer.". I don't know how to investigate this.

Printer is configured on a raspberry pi CUPS service and test works fine on the device. However, I can't add the printer to the system. Any ideas?

Edit: Printer is a Samsung ML-1860. I have the driver and PPD files to print via USB both on the server and Ubuntu. Problem is to make the network part work at the moment. I am not sure, what the network print protocol is implemented here. I have it simply on CUPS on the server side and "shared". I can access it via URL/browser. e.g. http(s)://:631/printers/Samsung_ML-1860

Both are in the same local home network/subnet.

  • Details needed. Which printer model? Which network printer protocol? Do printer and computer share same subnet?
    – N0rbert
    Nov 4, 2021 at 7:44
  • @N0rbert added details. I have done the basic investigation on networking, access etc. Nov 4, 2021 at 8:11

2 Answers 2


I met the same problem today. I have a server A, and a printer, and a Linux machine B, and some Windows machines C,D,... On Windows, I just follow this, it worked well. But when I try to add the printer for my Linux machine B (following the same steps with you), it just showed me 'Failed to add new printer'. (Ubuntu 20.04)

I don't know whether you have solved it, but I just solved it and am willing to share my solution, hope can help you :-)

My solution: use command line instead of GUI. Run this on my machine.

sudo lpadmin -p LaserJet -E -v

lpadmin is a tool specific for CUPS printer setting up. you can search for Google for more detailed usage.

In my command above, LaserJet is the name you want to assign the printer, and the address after -v is your address of printer. Mine is just for example, you should modify it according to yourself.

After running this in terminal, the printer showed up in [Settings]->[Printers].

In the end, I find it always a good choise to use command-line if you meet any problem in GUI operation. Because command-line will, if operation not successful, give you more detailed error log or sth like that. :-) This is also why I prefer Linux instead of Windows when programming and developing my project.


Try adding the user to ldadmin group by running the following in the terminal:

sudo adduser <username> lpadmin

where <username> is the username of the account you want to enable adding network printers on.

Reference: https://bugzilla.redhat.com/show_bug.cgi?id=1640815#c1

  • The user is already part of the lpadmin group. Nov 15, 2021 at 1:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .