1

I am trying to install dssp on ubuntu 12.04. I am new to ubuntu. I tried this

sudo apt-get install dssp

Please give suggestions.

1

DSSP is not in official ubuntu repositories, but you can install it manually:

sudo wget ftp://ftp.cmbi.ru.nl/pub/software/dssp/dssp-2.0.4-linux-amd64 -O /usr/local/bin/dssp

or

sudo wget ftp://ftp.cmbi.ru.nl/pub/software/dssp/dssp-2.0.4-linux-i386 -O /usr/local/bin/dssp

And for the end:

sudo chmod a+x /usr/local/bin/dssp
| improve this answer | |
  • Thank you for your answer.When I typed "chmod a+x /usr/local/bin/dssp" I got the following error message "chmod: changing permissions of `/usr/local/bin/dssp': Operation not permitted" . Any suggestions for correcting this? – naheed May 15 '12 at 14:17
  • oh sorry.. i forgot about sudo. You must type sudo chmod a+x /usr/local/bin/dssp. – us3r May 15 '12 at 15:42
  • Thanks for your comment. Do you know how to compile dssp? I can't see /usr/local/bin directory in my system. – naheed May 16 '12 at 9:32
  • If you really dont have /usr/local/bin directory, try sudo mkdir /usr/local/bin. If you wanna compiling dssp from source, you need download this and of course you need install build-essential – us3r May 16 '12 at 10:39
  • Thanks for your comment. I created /usr/local/bin directory. After this I typed "sudo chmod a+x /usr/local/bin/dssp" . But dssp is not in /usr/local/bin. So I tried to download dssp.tgz and extracted it. But I don't know how to execute it? – naheed May 17 '12 at 21:55
1

You can install DSSP in 12.04 with ppa:sfleischmann/tcbsys repository.

Follow these steps:

sudo add-apt-repository ppa:sfleischmann/tcbsys

sudo apt-get update

sudo apt-get install dssp
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.