35

I just moved up from 21.04 to 21.10. I have the 1Password extension installed in Firefox, which uses ctrl-period keystroke to launch the password manager. I've been using that since... uh... 18.10? 19.04? several years now at least with no problems between releases. But now on 21.10 ctrl-period is behaving very weird. It puts an underlined e in whatever text entry window has focus, anything I type then gets underlined, but if I hit enter the letters sometimes get jumbled up a bit, but often just the e and the underline get removed? It's really confusing... I have no idea what it's doing. This happens everywhere, terminal text editor, browser, IDE, todo list.... so I'm assuming it's some kind of system wide thing. What is this? What mode have I unknowingly stumbled into? Can I change what keys trigger it?

1
  • This was screwing me up in pycharm because it overwrote the shortcut for comment folding!
    – Hyperplane
    Mar 17 at 17:55

4 Answers 4

37

I've ran gsettings list-recursively | grep "<Control>" and noticed that, two new shortcuts were added:

org.freedesktop.ibus.panel.emoji hotkey ['<Control>period']
org.freedesktop.ibus.panel.emoji unicode-hotkey ['<Control><Shift>u']

Not sure what that is, but must be some new emoji picker feature. It doesn't seem to be working in my environment. It's possible to unset it though:

gsettings set org.freedesktop.ibus.panel.emoji hotkey "[]"

Thanks for raising this, by the way. I struggle with this new 1Passord issue for almost a week now and haven't though of checking shortcuts 🙂

5
  • 4
    aahhhh... THAT is promising.... and searching for "ibus emoji picker" tells me that a space character after the hotkey will display a menu of emoji classes... sure enough <ctrl>-period, space brings up that menu and dialog. When that dialog is open an "Emoji Picker" app shows up in my task bar.
    – cabbey
    Nov 2, 2021 at 2:24
  • 1
    Thanks for this answer. I was so frustrated, even I didn't know what was happening but you made my day. Feb 25 at 15:52
  • 1
    See also answer by pasman pasmański: can be changed using the tool ibus-setup
    – vanadium
    Mar 12 at 7:16
  • Same as through gsettings set it can be set to any other shortcut. Mar 12 at 7:34
  • Thank you so much! Life-saver, it was messing with one of my VSCode shortcuts.
    – xx1xx
    Jun 14 at 0:51
10

To answer the question "what is this?" and also to clear up the confusion about the underlined e you're seeing.

This is a new way to enter emoji. Here's how you use it. I was confused at first too. It's a little counter-intuitive, but you just type in the name of the emoji after ctrl-. and hit space enter like this:

ctrl-.

e

type the name of the emoji

eheart

hit space

e💌

hit space again to cycle through more options if you want more options

e❤️

hit enter to finish

❤️

4
  • Does not answer the question. Jan 2 at 16:27
  • 1
    How does it not answer? I'm telling you how to enter emoji using ctrl-.
    – fringd
    Feb 2 at 16:56
  • the question actually asks a bunch of questions. I'm answering "what is this?" I'll clarify in my answer
    – fringd
    Feb 2 at 16:57
  • This is actually a great user perspective answer!
    – cabbey
    May 3 at 18:01
9

You may change this shortcut in ibus-setup , tab Emoji

4

Description on how to change Ctl+. (period)

Open a terminal and type, so navigate to Emoji tab and edit that configuration, check the image below

ibus-setup
1
  • This does not work for me on Ubuntu 21.10 running on Xorg.
    – vanadium
    Apr 6 at 8:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.