I upgraded from ubuntu 11.10 to 12.04LTS version. Mine is 32bit OS. I run virtual box on my machine. In virtual box i run bt5r2(64bit) version. When i was running 32bit version of bt5r2,it worked fine. But this 64bit version of backtrack just freezes my pc and i have to restart my pc. But one thing i noticed is, i also run ubuntu 11.10 server Edition(32 bit). When i start backtrack first,it freezes my pc. but if i start ubuntu server,then backtrack it just runs fine. I think memory allocation is the problem. I enabled Hardware Virtualization(VT-d).

my pc configuration:

  • Intel® Core™ i3 CPU 540 @ 3.07GHz × 4
  • 4GB DDR3 RAM

Virtualbox supports your configuration (64-bit guest on 32-bit host), but there are some requirements and other caveats:

From the manual:

VirtualBox supports 64-bit guest operating systems, even on 32-bit host operating systems, provided that the following conditions are met:

  • You need a 64-bit processor with hardware virtualization support (see the section called “Hardware vs. software virtualization”).

  • You must enable hardware virtualization for the particular VM for which you want 64-bit support; software virtualization is not supported for 64-bit VMs.

  • If you want to use 64-bit guest support on a 32-bit host operating system, you must also select a 64-bit operating system for the particular VM. Since supporting 64 bits on 32-bit hosts incurs additional overhead, VirtualBox only enables this support upon explicit request.

  • Warning:

  • On any host, you should enable the I/O APIC for virtual machines that you intend to use in 64-bit mode. This is especially true for 64-bit Windows VMs. See the section called “"Advanced" tab”. In addition, for 64-bit Windows guests, you should make sure that the VM uses the Intel networking device, since there is no 64-bit driver support for the AMD PCNet card; see the section called “Virtual networking hardware”.

Please ensure you are meeting all these requirements, and that your memory allocation is reasonable -- try 512MB only for Backtrack to start with.

The other option is to try the free VMWare Player instead, which also supports this configuration, and see if it works any better.

Finally, even though you have 4GB RAM, if you can, you should just upgrade your physical machine to 64-bit 11.10 or 12.04. There should be no performance penalties with your configuration.


If backtrack 32-bit worked fine, why not just use that? I don't think backtrack 64-bit has many differences apart from the obvious.

  • I need the cause for the problem.Not the recommendations. – idiot May 15 '12 at 11:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.