8

This warning window keeps popping up since I've updated to Ubuntu 21.04 and 21.10. How do I get that solved?

enter image description here

5
  • This is quite surely a bug or some old software (seems to be "Dell Linux Assistant" <-- ). isAlive() was renamed to is_alive() in python 3.9.
    – pLumo
    Oct 31, 2021 at 8:23
  • 1
    Did you use preinstalled Ubuntu from Dell?
    – pLumo
    Oct 31, 2021 at 8:26
  • 1
    @pLumo Ubuntu 18.04 LTS was installed when I bought it. Then I upgraded to 20.04 LTS, and now to 21.10 Oct 31, 2021 at 8:29
  • There wasn't such a problem with 20.04 Oct 31, 2021 at 8:30
  • 3
    sure, because 20.04 used python 3.8
    – pLumo
    Oct 31, 2021 at 8:30

1 Answer 1

16

The Error is, that Thread.isAlive() is not known by your python version, which has changed from 3.8 to 3.9 due to the upgrade. In 3.9, the attribute has been renamed to is_alive().

Seems you have a preinstalled Ubuntu from Dell, that has some software installed ("Dell Linux Assistant") that is not compatible with python 3.9.

You should either

  • ask the Dell support if they have a fix.

  • or simply try to get rid of that software, e.g.:

    sudo apt remove dell-recovery dell-linux-assistant
    
  • or (what I'd recommend) reinstall a clean Ubuntu without Dell bloatware.

3
  • 1
    If you have asked dell or found a way to remove the software, it would be cool, if you could share your knowledge. I can also add this to my answer if it is okay for you.
    – pLumo
    Oct 31, 2021 at 8:57
  • 2
    thanks, I've purged dell-recovery and dell-linux-assistant and now it's solved Oct 31, 2021 at 9:24
  • Dell preinstalled systems - as far as I recall - use official Dell repositories because they do things slightly different (like disabling the Windows key). By switching to official Ubuntu you get things like this. Nov 1, 2021 at 18:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .