In Ubuntu 21.10, Firefox 93.0 can't open a file in a hidden directory like /home/alba/.toto/0000000d.html.

(Whatever the name and content of the HTML file, you can use an empty file.)

Nor does Chromium 95.0.4638.54 snap but Dillo version 3.0.5 and Google Chrome 90.0.4430.93 can do it.

In 21.04, Firefox 93.0, Dillo 3.0.5 and Google Chrome 90.0.4430.93 can do it, only Chromium 94.0.446.71 snap cannot, so this is a regression.

Can you confirm? Is it worth reporting a bug? Is it Firefox or Ubuntu bug?

I found this by using Claws Mails that stores HTML mail files in ~/.claws-mail/.

More simply

Checked with Ubuntu 22.04.

Take any HTML file named index.html that Firefox or Chromium can open. Rename it with a leading dot .index.html, then Firefox or Chromium cannot open it. Firefox error message (in window) :

Access to the file was denied

The file at /home/me/.index.html is not readable.

    It may have been removed, moved, or file permissions may be preventing access.

With or without dot, the Failed to load module "canberra-gtk-module" error also occurs in Terminal so it is probably not the cause.

% snap list
chromium                 101.0.4951.41
firefox                  99.0.1-1

dillo has no problem.

  • How are you opening the file? I am able to open an empty file ~/.toto/0000000d.html using the *.deb version of Firefox 93.0 in Ubuntu 21.10. I can drag the file from Nautilus onto Firefox, and it opens. Also, I can right-click on the file and select to open the file in Firefox, and it opens.
    – Enterprise
    Oct 27, 2021 at 20:46
  • I open the file by right clicking on it in Nautilus. Oct 27, 2021 at 21:10
  • I have also tried to open in the command line firefox /home/alba/.toto/0000000d.html, same result. But I see this Gtk-Message: 22:11:44.197: Failed to load module "canberra-gtk-module. Oct 27, 2021 at 21:12
  • I don't have this message in 21.04. Found this askubuntu.com/questions/342202/… but sudo apt install libcanberra-gtk-module libcanberra-gtk3-module does not remove the message. Oct 27, 2021 at 21:26
  • 1
    firefox ~/.toto/0000000d.html just opens the (blank) file in Firefox for me, without errors. Try the *.deb version. May be the snap sand-boxing is causing this? By the way, I have libcanberra-gtk, libcanberra-gtk0, libcanberra-gtk3-0, and libcanberra-gtk3-module installed.
    – Enterprise
    Oct 27, 2021 at 21:37

2 Answers 2


For Claws-Mail, you can just create a "tmp" directory in your home directory and move the "mimetmp" directory used by Claws-Mail inside:

  1. Close Claws-Mail.

  2. Move the "mimetmp" directory to a non-hidden "tmp" directory:

    mkdir ~/tmp
    cd ~/.claws-mail
    mv mimetmp ../tmp
    ln -sf ../tmp/mimetmp

You can now restart Claws-Mail and open attachments with Firefox or Chromium.


I begged advice from the Claws-mail mailing list.

This should work:

mv .claws-mail claws-mail ; claws-mail --alternate-config-dir claws-mail

Deb Ubuntu can still be installed in Ubuntu 22.04.

If the above link dies:

sudo snap remove firefox

sudo add-apt-repository ppa:mozillateam/ppa

echo '
Package: *
Pin: release o=LP-PPA-mozillateam
Pin-Priority: 1001
' | sudo tee /etc/apt/preferences.d/mozilla-firefox

echo 'Unattended-Upgrade::Allowed-Origins:: "LP-PPA-mozillateam:${distro_codename}";' | sudo tee /etc/apt/apt.conf.d/51unattended-upgrades-firefox

sudo apt install firefox

Other ways :

  1. Compile Firefox from source.
  2. Switch to another Linux distribution that does not force to use Snap.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.