2

I am using Ubuntu 21.10. I tried to transfer files from my Android phone (Redmi Note 4) to my laptop via USB cable by enabling the file transfer option on the phone. Ubuntu detects my phone, but when I tried to open files in my phone on the laptop, it shows:

Unhandled error message: The name :1.103 was not provided by any .service files

It doesn't open the contents on my phone. Please help.

1
  • The variety of phones and other issues makes this a tough one. You are not alone. Have you enabled developer options? {do so by tapping build number 7 times or so.} Watch your phone when you connect and see if you need to allow something or choose what protocol to use. I have battled this for years. I gave up and just use MixPlorer and ftp. Slightly slower but very easy to navigate. Oct 26 at 4:29
2

On many Android devices, you'll need to drop down the Notifications and select the USB connection, then tell it you want to enable storage or something like that. For security reasons Android defaults to Charging mode when you plug into a computer. Once you've done this, you should see a notification in Ubuntu that a new removable media device has been connected.

2

I just had almost exactly this same problem with Ubuntu 20.04 and an Umidigi Android phone. I've never had trouble connecting my phone to the same computer under Windows 10, so I surmised that there was no problem on the phone's end. I was also able to switch the phone's connection to PTP and have it work in Ubuntu, but of course the phone would only transfer photos in that mode.

After digging around I found that Ubuntu doesn't include MTP support by default, which is needed to do general file transfers with Android. I opened a terminal and typed:

sudo apt-get install gmtp

and after I shut down and restarted the machine, I was able to connect my phone and browse its files as I expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.