I recently upgraded to 21.10. During upgrade the system asked me which key I wanted to use for latin character input. I answered Alt Gr. However I’m an Icelandic keyboard user and use that key for a third level shift. E.g. to type @ I used to be able to type Alt Gr + Q. Now I’m not longer able to, it just types q. In fact pressing Alt Gr seems to switch over to the English keyboard. I don’t want this behavior as Super + Space already does this.

Screenshot of the keyboard setting

I tried going to the Keyboard settings and under “Alternate Character Key” set it to “None”. This disables the temporary english keyboard but typing Alt Gr now has no effect at all. In fact it functions as a simple Alt.

If I go looks at the keyboard layout, it says that the key is a level 3 shift, however I can’t figure out how to set it back to being an actual level 3 shift like it was before I upgraded to 21.10 (in the meantime I’ve remapped my Caps Lock to level 3 shift).

The keyboard layout

Here is the output of cat /etc/default/keyboard:

$ cat /etc/default/keyboard 
  • 2
    Can you please edit your question and show us the output from this terminal command: cat /etc/default/keyboard Oct 24, 2021 at 7:20
  • @GunnarHjalmarsson Sure, edited the question. Oct 25, 2021 at 17:16

2 Answers 2


In Gnome Tweaks, "Keyboard & mouse", "Additional Layout Options", "Right Alt (while pressed)" will be checked according to the behaviour you describe. Uncheck it to revert to the default behaviour as defined in your keyboard layout. Install Gnome Tweaks if needed – it is not installed by default.

  • 1
    I think it's also advisable to make the equivalent change in /etc/default/keyboard or else the undesired setting may re-appear. Oct 24, 2021 at 16:41
  • @GunnarHjalmarsson not as long as Gnome Shell is used, although changing it "deeper" in the system indeed will transfer the change to any desktop or window manager you may want to install in the future. Changing /etc/default/keyboard requires root permissions and editing a system file, whereas current answer allows to apply the setting as a user.
    – vanadium
    Oct 25, 2021 at 16:47
  • My experience is that if the xkb-options dconf key has an empty value, it imports whatever is in XKBOPTIONS in /etc/default/keyboard. Hence my advice. Oct 25, 2021 at 16:55
  • Thanks. This did exactly what I needed. Oct 25, 2021 at 18:40

In addition to the steps described in vanadium's answer, I would suggest that you open the /etc/default/keyboard file for editing and replace this line:




That should prevent you from the risk that the problem re-appears.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .