0

After upgrading to Ubuntu 21.10, my wifi not showing up.


Output of following command

sudo lshw -C network 
  *-network                 
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eno1
       version: 15
       serial: b4:b6:86:0f:79:a1
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8168 driverversion=8.048.03-NAPI duplex=full ip=192.168.1.11 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:126 ioport:4000(size=256) memory:b1104000-b1104fff memory:b1100000-b1103fff
  *-network UNCLAIMED
       description: Network controller
       product: RTL8723DE 802.11b/g/n PCIe Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: ioport:3000(size=256) memory:b1000000-b100ffff
1
  • You probably installed some drivers on the previous version and they aren't supported by the new kernel.
    – Pilot6
    Oct 19 '21 at 13:36
0

Saw this result after some googling: https://ubuntuhandbook.org/index.php/2021/01/install-rtl8188eu-rtl8723ds-drivers-ppa-ubuntu-20-04/

Though this guide says it's for 20.04, the PPA page suggests that this PPA works for Impish (21.10) too.

Connect to the internet via ethernet, which seems to be working according to your lshw, and run:

sudo add-apt-repository ppa:kelebek333/kablosuz
sudo apt update
sudo apt install rtl8723de-dkms
1
  • followed your instruction by letter and everything installed perfectly but wifi did n't work, though i have disable secure boot and follow the "modprobe" command line. see if you can still help me. I can't share the result of your instructions for there is a limit on characters.
    – MOHIT
    Oct 21 '21 at 9:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.