1

I yust installed Ubuntu 20.04 on my Surface Laptop 1 and I have Thermal Throttling issues.

I tried everything from using the tee command:

echo 65 | sudo tee /sys/devices/system/cpu/intel_pstate/max_perf_pct

To using this fix: https://github.com/linux-surface/linux-surface/wiki/Surface-Laptop 1

But noting seems to work for me

My specs are:

Core i5-7200U

8Gb of ram

Intel HD 620 Graphics

8
  • 1
    Are you sure it is thermal throttling and not some other throttling such as power limits? Try limiting "max_perf_pct" even more. Try disabling turbo. If your CPU frequencies are stuck low, there might be some other reason. If I ever use thermald, I prefer a very simple config file, such as this Oct 17, 2021 at 20:37
  • 1
    I prefer to use turbostat (linux-tools-common package) to monitor power, temp, CPU frequency. Such as: sudo turbostat --Summary --quiet --show Busy%,Bzy_MHz,IRQ,PkgWatt,PkgTmp,RAMWatt,GFXWatt --interval 6 Oct 17, 2021 at 20:51
  • How can I exacly disable Turbo boost. Vesides Thermald dosent seem to use the scrips that I provided under /etc/thermald/thermal-conf.xml for some reason Oct 18, 2021 at 1:58
  • Also thank you for your help Oct 18, 2021 at 2:26
  • see here for disabling turbostat after boot. You might find you need to disable it before boot, in BIOS, at least as a test. Is the thermald service running on your computer? sudo systemctl status thermald Oct 18, 2021 at 14:18

1 Answer 1

0

Not an surface user, but I was affected by this:

https://phoronix.com/scan.php?page=news_item&px=Platform-Profiles-Axboe https://www.phoronix.com/scan.php?page=news_item&px=Linux-ACPI-Platform-Profile

If you are using a linux kernel >= 5.1 check if modifying /sys/firmware/acpi/platform_profile solves your problem

note: there is /sys/firmware/acpi/platform_profile_choices showing possible values

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .