I have an Asus G73JW laptop which has an internal subwoofer built-in. Currently, the system detects the internal speakers as a 2.0 system (or I can change do 4.0 is the only other option). I found a bug report here: https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/673051 which discusses the bug and according to them a fix was sent upstream back at the end of 2010. I would have thought this would have made it into 12.04 but I guess not?

I tried following the link given at the very bottom to install the latest ALSA drivers, here: https://wiki.ubuntu.com/Audio/InstallingLinuxAlsaDriverModules however I keep running into an error when trying to install:

sudo apt-get install linux-alsa-driver-modules-$(uname -r)
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package linux-alsa-driver-modules-3.2.0-24-generic
E: Couldn't find any package by regex 'linux-alsa-driver-modules-3.2.0-24-generic'

I believe I have added the repository correctly:

sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
[sudo] password for codyloco: 
You are about to add the following PPA to your system:
 This PPA will be used to provide testing versions of packages for supported Ubuntu releases.
 More info: https://launchpad.net/~ubuntu-audio-dev/+archive/ppa
Press [ENTER] to continue or ctrl-c to cancel adding it

Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /tmp/tmp.7apgZoNrqK --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver hkp://keyserver.ubuntu.com:80/ --recv 4E9F485BF943EF0EABA10B5BD225991A72B194E5
gpg: requesting key 72B194E5 from hkp server keyserver.ubuntu.com
gpg: key 72B194E5: public key "Launchpad Ubuntu Audio Dev team PPA" imported
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)

And I also ran an update as well (followed the instructions on the fix above).

Any ideas?


It is very unlikely that a bug was fixed a year ago, was provided with up-to-date drivers from the ubuntu-audio-dev ppa, but did not make it for the release in 12.04. LTS.

Therefore I suggest you first have a look whether your /etc/pulse/daemon.conf is set to enable 2.1 sound. There should be the following entries:

default-sample-channels = 3
enable-lfe-remixing = yes

Try if that helps you to get sound to your subwoofer before you take efforts to intall possibly unstable new drivers.

At present there are no newer drivers than those installed by 12.04 available from the audio-dev-ppa (1.0.25+dsfg-0ubuntu1). This may change however in the near future. According to the release notes for ALSA drivers custom kernel modules need to be built from source:

A custom alsa-modules package can be built from the sources in the alsa-source package using the m-a utility (included in the module-assistant package). release note for alsa-base

  • Thanks for the reply! (I saw no notice that an answer was posted, weird). I uncommented those two lines in the file as you said and changed their values (were set to 2 channels, and no remixing) but everything seems the same as before. The sound control still says Analog Stereo Duplex and no 2.1 setting or Subwoofer volume control. Playing sounds creates no output on the subwoofer either :( – CodyLoco May 14 '12 at 20:11
  • @CodyLoco: Did you also restart pulseaudio after editing the daemon.conf? Just log out and log back in should do it (or run pulseaudio -k in a terminal) – Takkat May 14 '12 at 20:20
  • I actually rebooted the entire computer to make sure, sorry I forgot to mention that! No fix :/ – CodyLoco May 14 '12 at 20:29
  • Sorry to hear. But it sure was worth a try. I'll put an edit to my answer regarding the drivers from ubuntu-audio-dev ppa. – Takkat May 14 '12 at 21:23
  • Either way, I guess I'll have to wait until new drivers are released then to maybe have a fix? – CodyLoco May 14 '12 at 22:57

After trying the changes on /etc/pulse/daemon.conf without success, I added to etc/modprobe.d/alsa-base.conf this line at the end:

options snd-hda-intel model=asus-mode4

Now it's working perfectly!

  • Good to let us know, according to a post on the pulse planet you shouldn't tinker with quirks. They should be picked automatically. But nothing is perfect. – LiveWireBT Sep 28 '12 at 17:18

Oooh, Hello every one, I have other asus with the subwoofer, and I was thinking how this work, because with the new versions of pulseaudio don't run very good, and with that config only for me plays the right with the subwoofer, for repair this is very simple, first:

in /etc/pulse/daemon.conf change the line

; enable-lfe-remixing = yes


enable-lfe-remixing = yes

in /etc/pulse/client.conf change the line

; autospawn = no


autospawn = no

next in the etc/modprobe.d/alsa-base.conf or etc/modprobe.d/alsa.conf add this line in the end:

options snd-hda-intel model=XXXX

where XXXX can be asus-mode1, asus-mode2, ... asus-mode8

depending nootebook is one of thats, and, how we choose one?

first in this topic is recommend add in the /usr/share/pulseaudio/alsa-mixer/profile-sets/extra-hdmi.conf

[Mapping analog-surround-21]
device-strings = surround40:%f
channel-map = front-left,front-right,lfe,lfe
paths-output = analog-output analog-output-speaker
priority = 7
direction = out

(depending of the kernel you must change the last line for direction = output, at least in the kernel 3.8.0-30 you must do) but in my Asus R401V8 that don't works fine, but we will use this profile for tests and this line in the terminal (don't run this as root)

pulseaudio -k && modprobe -r snd-hda-intel && modprobe snd-hda-intel model=asus-modeX && pulseaudio --start

if the pulseaudio is shutdown this line will pass a message error, before of execute use pulseaudio --start and you don't run jack for this and close all the players, next, we will replace the X with the modes 1 to 8 for test:

pulseaudio -k && modprobe -r snd-hda-intel && modprobe snd-hda-intel model=asus-mode1 && pulseaudio --start

and we will check the sound setting, first, first we must check if is available the Analog Surround 2.1 in the profiles (plase select the speaker card of the computer), if not, we close the windows, execute the line with the next asus mode, and check the profile again, if exist the profile we will test the speakers, and the subwoofer must sound, you must see 3 options in the speakers test, the left, right, and subwoofer, all most play something, okey, in my case works with asus-mode5, but with the before configuration of audio profile, the subwoofer only play the sound of right speaker, I use this profile:

[Mapping analog-surround-21]
device-strings = front:%f hw:%f
channel-map = left,right,lfe,lfe
paths-output = analog-output analog-output-lineout analog-output-speaker analog-    output-desktop-speaker analog-output-headphones analog-output-headphones-2
paths-input = analog-input-front-mic analog-input-rear-mic analog-input-internal-mic   analog-input-dock-mic analog-input analog-input-mic analog-input-linein analog-input-aux    analog-input-video analog-input-tvtuner analog-input-fm analog-input-mic-line analog-    input-headphone-mic analog-input-headset-mic

Is the same as the analog-stereo but with the lfe,lfe in the channel map, and works fine for me, you can test something how this:

[Mapping analog-surround-21]
device-strings = surround40:%f
channel-map = left,right,lfe,lfe
paths-output = analog-output analog-output-speaker
priority = 7

make little changes, for check the speakers you most play a audio file, music with bass ideally for listen and check.

This method works in: Ubuntu, Debian, Arch, Gentoo, basically, the distributions with alsa and pulseaudio.

Good Bye, Sorry for my bad english.


I still needed to add a 2.1 surround system by adding the following lines to /usr/share/pulseaudio/alsa-mixer/profile-sets/extra-hdmi.conf:

[Mapping analog-surround-21]
device-strings = surround40:%f
channel-map = front-left,front-right,lfe,lfe
paths-output = analog-output analog-output-speaker
priority = 7
direction = out

After that there was an additional mode "Analogue Surround 2.1 Output" in the sound settings which lets me control the subwoofer. See more detailed instructions here. This worked on Asus N76VM running Ubuntu 12.10 with resulting in excellent sound quality.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.