Yesterday the internet wasn't reachable. Firefox wasn't working, in terminal I tried links2 www.cnn.com and it wasn't working either; I tried dig <somesite> and it was working; I also tried with a wifi dongle. As it comes out of nothing when I turned on the PC, in the mmid-morning the problem went away and everything worked in regular way. I though it was over but today is even worse. I tried

  • unplug the eth cable and plug it again
  • using the USB dongle (already used in the past) to connect via wifi
  • links2 in terminal
  • changed the DNS from OpenDNS to the Google one
  • changed from "DHCP" to "manual" in the connection parameters in network setting
  • reset the router

To check if was just my user or the entire system i logged as my sister's user and verified that user can't use internet, too.

As a final test I started windows which is in dual boot on the same machine, that means the averything is the same in ubuntu. It worked! I'm using it to write now.

I haven't changed nothing in the last two days (14 oct 2021); for what I remeber, where was an automatic update of the network stuff and of the entire kernel.

Am I the only one facing this issue?

Any suggestion to investigate what is going wrong?

Thank in advance

  • Look at the logs! sudo journalctl -b 0 -u NetworkManager. Read man journalctl. Read askubuntu.com/questions/how-to-ask
    – waltinator
    Oct 17, 2021 at 3:45
  • nothing worse than a -ve rating without any reason, especially when you are a new user. it is kinda disgusting how humans are. So removed the -ve. Apr 23, 2022 at 10:22

2 Answers 2


I thought the problem was over, but, sadly, this morning I can't use internet. :(

I looked in the shell's history and retyped some of yesterday's command

sudo ip link set enp3s0 down

sudo ip adrr flush enp3s0 

sudo ip link set enp3s0 up

sudo dhclient -r

sudo dhclient

Just changes the port name from post in askubuntu

and now I'm online again. :-)


SOLVED (I believe, I haven't rebooted, yet)

I removed the PIA VPN autostart at boot, and everything looks ok: I'm writing with linux, now.

---------- EDIT/UPDATE -----------------------

I was planning to complain with PIA - after all I lost two days - but I checked that I have ver 1.28 and the 1.3 was available; after the upgrade even with VPN on there wasn't (isn't) any problem.

  • There isn't so much to add. The problem was due to the VPN software.
    – mune72
    Oct 17, 2021 at 20:53
  • 1
    There isn't so much to add. The problem was due to the VPN software. As first step I disabled the VPN, then -before complaining with PIA, luckly- I got I was running the version 1.28 of PIA's software; I upgraded to 1.3 and now the network is OK even with the VPN on.
    – mune72
    Oct 17, 2021 at 21:02
  • Please edit and put additional info in your answer, not in the comments. Oct 18, 2021 at 1:49
  • 1
    I edited the post yesterday, it already says the same things the comment does. I don't see what else I can add.
    – mune72
    Oct 18, 2021 at 10:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.