1

I'm trying to install Ubuntu on my computer (MSI GS66 Stealth 11UH) but the SSD is not detected. I'm using a bootable key of Ubuntu 21.10. I thought it could be related to SATA mode being RAID instead of AHCI, but there is no such option in the BIOS, so I assume my computer only supports AHCI in the first place. The hardware is fairly recent, maybe it is just not supported properly yet. I had touchpad issue using Ubuntu 20.04 image and that's why I was trying to install Ubuntu 21.10 instead.

Note that I shrunk the windows partition using Windows partition management tools before trying to install Ubuntu.

4

1 Answer 1

3

After some trial and error, the NVME drive was properly detected on Ubuntu 20.04 and 21.04. It is only not working on the latest 21.10 with default kernel version (5.13), while if I use an older one (5.11) it is working fine even on 21.10. I would say that the original issue is solved then, but unfortunately the wifi card (intel AX1675X) was still not working on any version... It turns out that installing backport-iwlwifi-dkms fixed this last issue. So now it is all good !

EDIT: Now it is working on Ubuntu 22.04.0 with the default kernel (5.15 for me), but I cannot adjust the screen brightness. I'm using Nvidia 510 driver with on-demand setting.

7
  • I have same problem now. NVME SSD PCI card, Ubuntu 21.10 r5.13, Nautilus shows no SSD card. Dolphin shows the card, but the properties are blank. So your solution is to revert backwards to an earlier kernel? How is such a solution? Can anybody else comment please?
    – rob grune
    Nov 9, 2021 at 9:13
  • I can confirm that reverting the kernel version works. 5.11 is not so old so it is not a big limitation. I'm looking forward for the stable release of kernel 5.15 coming with ubuntu 22.04 to see if it helps.
    – milembar
    Nov 9, 2021 at 10:02
  • Same issue here, also wifi adapter still broken on 21.10 with kernel 5.11. The backport-iwlwifi-dkms package is install.
    – Fraak
    Nov 9, 2021 at 13:39
  • @Fraak Hum... It is curious. I'm quite sure it is all I did to make it work (with a reboot of course). You should look other posts related to network issue using intelAX1675X, I found many of them discussing different solutions, all related to install backport-iwlwifi-dkms one way or the other.
    – milembar
    Nov 9, 2021 at 17:55
  • Go on then, I just feel like nobody care. Getting linux based OS working on MSI stealth machines has always been a huge mess since the first model more than 5 years ago, and we keep facing similar issues.
    – milembar
    Nov 10, 2021 at 8:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.