1

After updating to 21.10 today i cant pair and connect my bluetooth headphones (Sony WH-1000XM4), bluetooth itself is working as i can connect and use a bluetooth mouse. The headphones worked flawlessly before the update. I use kde on x11 as my de. I've tried to sudo systemctl restart bluetooth to no effect. Is there a way to get them to work again?

edit: bluetoothctl actually shows that i can pair the headphones but connecting fails with an error:org.bluez.Error.Failed

8
  • What sound server you use: pulseaudio or pipewire (check pactl info output) Oct 15 '21 at 18:22
  • @pasmanpasmański i use pulseaudio
    – Sikora77
    Oct 15 '21 at 18:33
  • WH1000XM2 works on Ubuntu (gnome de). Maybe you should repeat pair+trust steps ? Oct 15 '21 at 19:20
  • already done that a few times, does not seem to work, in bluetoothctl everything seems fine but it just does not connect, when i try to do that i get protocol not available error
    – Sikora77
    Oct 15 '21 at 19:26
  • You may check installed packages : apt list --installed '*blue*' , compare with pastebin.com/u713BDgx Oct 15 '21 at 19:43
0

I had the exact same problem that you are describing, also after upgrade to 21.10. For me, the solution described here worked, except the module was already there so I had to --reinstall:

sudo apt install --reinstall pulseaudio-module-bluetooth
pactl load-module module-bluetooth-discover

Then remove and pair the device again.

1
  • thank you so much, worked like a charm
    – Sikora77
    Oct 15 '21 at 20:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.