4

I upgraded my system from Ubuntu 20.04 to 21.10. After upgrading, I noticed I had 2 Firefox icons. So, I decided to reinstall it. I tried

sudo apt purge firefox && sudo apt autoremove

But, it only removed one icon. After that, I logged out and logged back in. But, It didn't help. Then, I tried,

sudo apt list --installed | grep firefox

and uninstalled all the packages. It still didn't work. So, I followed this question's answer, Removing Firefox in Ubuntu with all add-ons like it never existed. It didn't help either. Now, if I try,

firefox -v

I get the version of firefox & I can open firefox from Applications. But, if I try uninstalling firefox again, I get

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package 'firefox' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

How, do I uninstall Firefox? I'm asking this question from Google Chrome.

3
  • 1
    It seems to me, the problem is not firefox package, but you had two different dekstop entries for firefox. Try sudo find / -type f -name "firefox*.desktop" and see if it comes with anything.
    – Liso
    Oct 15 at 14:18
  • @Liso Hello, I can open firefox even after this steps. And, as you asked, If I try, sudo find / -type f -name "firefox*.desktop", I get /snap/firefox/631/firefox.desktop /snap/firefox/631/meta/gui/firefox.desktop /var/lib/snapd/desktop/applications/firefox_firefox.desktop find: ‘/run/user/1000/doc’: Permission denied find: ‘/run/user/1000/gvfs’: Permission denied Oct 15 at 14:24
  • An upgrade from 20.04 should currently only take you to 21.04 (ie. next supported release) - so you've gone outside of the intended upgrade paths. Your issue is likely the consequence of how you forced your unsupported upgrade.. If moving from 21.04 to 21.10; in some cases no firefox changes occur; in others the deb package gets removed & replaced by a firefox snap; but 20.04 to 21.10 isn't supported yet (and won't be till 21.04 reaches EOL)
    – guiverc
    Oct 15 at 22:13
7

From your reply, I see you still have snap version of firefox. Try uninstalling it.

sudo snap remove firefox
3
  • Thanks, it helped me a lot. From where should I reinstall firefox now? APT or SNAP ? Oct 15 at 14:33
  • 4
    Well if you ask me, I prefer apt over snap, it's easier to manage and I'm more familiar with it. But the choice is yours.
    – Liso
    Oct 15 at 14:37
  • Thanks for your advice ^_^ Oct 15 at 14:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.