I have searched a lot before but couldn't find a solution for a problem I'm facing with a screen session in a Ubuntu 20.04 VM.

In this VM I have a pypi-server configured to host a python package. I should be able to install this python package in a local env using a pip install command. It was working until I had update the source code, to include versioning.

After I included the versioning in the package and tested in my machine (everything was fine) I pushed it to the repository on my branch and them, pulled the remote copy of the package with these new features.

Once I made it, I generated a sdist, bdist and tar.gz with python setup.py, I 've checked the generated packages on the dist folder and them copied the tar.gz to a folder called packages, used for the screen.

I followed all these steps but when I tried to install the package locally on my machine I received this message:

ERROR: THESE PACKAGES DO NOT MATCH THE HASHES FROM THE REQUIREMENTS FILE. If you have updated the package versions, please update the hashes. Otherwise, examine the package contents carefully; someone may have tampered with them.
    package from
        Expected md5 0bc256477dc39af8f5e0fd5c3bfba88e
             Got        8f1cfff4716df907cb98654420f9c566

(I have omitted sensible information)

Well, after receiving this error I checked the screen session it presented this description:

WSGI application error

Does anybody knows what might be going on? If something is not clear I can provide more details.

1 Answer 1


I am answering my own question because maybe this can be useful to someone else in the future.

I am not 100% sure which of the 3 things I've done was the real solution for the problem, but, basically,I did this:

  • Rebooted the VM;
  • Created a new tmux session to host the pypi server;
  • Chenged the final number of the version, so the version I was facing problems was x.x.3, I made a downgrade in the final number (the main package code was exactly the same as before adding versioning) to x.x.2.

After these changes it worked as expected.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .