0

I have download latest version of VS code 1.61 and when I click on .deb file, ubuntu ask to remove previous version of vs code and my fear is that will it remove my workspace and all settings if I delete the previously installed vs code.

ubuntu softwares asking to remove vscode

Ubuntu 20.04

someone can guide me please here

2
  • although I am able to update using command sudo snap install code --classic but it added another instance of vs code in ubuntu.
    – xkeshav
    Oct 13, 2021 at 5:13
  • 1
    Is there a reason you really need that particular version? The snap should be reasonably up-to-date. You're kind of playing with fire, so the preemptive solution is to back up the data you are concerned about losing. Nobody can give you a guarantee that you won't lose your data otherwise.
    – Nmath
    Oct 13, 2021 at 5:32

1 Answer 1

2

Replacing the previous version will not delete your workspace or your settings. Those are stored in your home directory separately from the program files. The package manager will only touch the files that it installed, not files that VS Code created.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .