1

I bought an Asus Vivobook F513 laptop which has the MediaTek MT7921 Lan Card.

As soon as I installed Ubuntu 20.04LTS to dual boot with windows, I noticed I didn't had either Wi-Fi or Bluetooth.

After a lot of debugging and googling, I found my kernel version was 5.11, and apparently support to my chipset was only added after version 5.12.

As soon as I updated the kernel with these instructions and disabled Secure Boot on BIOS I got Wi-Fi working fine.

sudo add-apt-repository ppa:cappelikan/ppa
sudo apt update
sudo apt install mainline

Still, the problem with the Bluetooth persisted, when I try to enable it on Ubuntu Settings it just remains disabled.

I reformated the Ubuntu partition and this time I installed Ubuntu 21.10 (Impish Indri) Beta which comes with the 5.13 kernel, but then I updated it to the 5.14.11 version, which I'm currently using. still, no bluetooth.

If I open terminal and type hcitool dev it show's me just Devices: and nothing more.

Instead, if I try to input bluetoothctl and on the next screen show it returns No default controller available.

Last but not least, if I type lspci I get 0000:02:00.0 Network controller: MEDIATEK Corp. Device 7961.

Any thoughts on how to make linux recognize my bluetooth? I've searched everywhere and apparently there's more people with similar issues, I'm now considering returning my laptop that only has a few days because of this.

I also have a usb bluetooth adapter, and as soon as I plug it in it just works.

Thanks!

***** UPDATE *****

Meanwhile I reformated my partiton and installed Ubuntu 20.04.3 LTS for better support, but had to upgrade my kernel version to 5.14.11 in order to get Wi-Fi working, just as mentioned above.

All of the listed commands above still provide the same output, still no bluetooth.

3
  • 2021 Asus Zephyrus G15 here. Also MediaTek MT7921 PCIe. Worked fine in Windows until I nuked the default drive. I have tried installing Fedora 35, Pop OS! 21.10 and Ubuntu 21.10. Of the three installations, Ubuntu 21.10 provides Wifi support, but no Bluetooth, the other two provide Bluetooth, but no Wifi. Pop & Fedora were running Kernel 5.15, Ubuntu 21.10 is running 5.13. I tried upgrading my Ubuntu 21.10 Kernel (5.13) to 5.15, but unfortunately, this Kernel version does not support ZFS, which I'm using (for no good reason), so that didn't work for me either.
    – Luke Bayes
    Dec 27 '21 at 18:02
  • Quick update: I had disabled secure boot before all three installations with no luck. I also tried ASUS USB-AC53 NANO USB and NETGEAR AC1200 WIFI USB. Neither worked. I was able to get Wifi and BT by installing Intel Wireless-Ac 9260, 2230, 2X2 Ac+Bt, Gigabit mini pcie card.
    – Luke Bayes
    Jan 16 at 21:46
  • 1
    It's shame to have to install new hardware, my Asus Book is brand new.. maybe I will wait for a new kernel version to definitively fix this. Thanks anyway for the heads up Luke. 2 days ago
0

It should be supported on the 5.15.X kernel. I was having the same issue with Bluetooth but that fixed it. I can't stay on it right now though because I can't seem to get sleep working properly and I'm not sure why, so for now I'm stuck with no bluetooth...

2
  • 1
    Thanks for the reply. I was having the same issues, also tried with the new Kernel, it worked for a few days... until it didn't. I'm now using Windows 11 with WSL and honestly, I'm loving it. Nov 12 '21 at 0:11
  • Same issue here with the sleep, hope the new kernel versions fix that. About using WSL, it's a bit tricky, if I'm working on a Javascript project I have to reference the project from \\wsl$\ path, if it's a Java project I have to asign a letter to that "WSL partition" (let's say, Z:), and them open the project from that partition. Jan 2 at 11:48
0

Hi I have the same network card, and I have enabled dual boot between windows 11 and ubuntu 20.04

I have updated the kernal to be 5.15.0, and I have followed these guidelines this, you have to make sure that secure boot is disabled.

then shutdown the device and start it again and it worked fine for both wi-fi and bluetooth

2
  • Windows 11 requires Secure Boot ON. Jan 17 at 15:36
  • Thank you for your answer Abdullah, have you had more problems since dual booting? I also tried upgrading to newer kernal versions but from time to time the wifi/bluetooth would just vanish again. And by the way ChanganAuto, I can disable Secure Boot and still use Windows 11. 2 days ago

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.