Since upgrading to Ubuntu 12.04, the disk checker has run approx. half of the times I powered on my laptop. Sometimes I let it complete, but if I'm in a rush I skip it. Some of the times that it runs it comes out fine, some other times it comes up with an error, I ask it to fix, then it says that it can't mount /tmp/.

Anyway, after a disk check like that (which 'fixed' something, but couldn't find /tmp/), the laptop rebooted, and I got the dialog about running in low-graphics mode.

I had a look around the menus, the restoring to default and restoring to backup neither seemed to do anything (I clicked on them and the menu just reappeared), and editing the config file did nothing either.

From there, I went into low graphics mode to find ways to fix this.

The first thing I came across was entering sudo apt-get install ubuntu-desktop, after hitting Ctrl+Alt+F1. Ctrl+Alt+F1 did nothing for me, but I opened the terminal, entered the command and it ran, saying that there were no packages that needed installing.

(as an aside note, from the first menu that asks whether I'd like to use low-graphics mode, try to fix this, terminal, etc, if I select terminal I don't actually get to the terminal login, just some progress reports about stuff loading).

Next I tried dpkg-reconfigure -phigh -a, which ran for about half an hour, outputting nothing. I rebooted and the problem persisted.

From the would you like to use low-graphics mode menu, I looked at the log files. On the Server (or xserver, can't remember) file, it said

Fatal server error:
Server is already active for display 0
 If this server is no longer running, remove /tmp/.X0-lock
 and start again.

So I went, found and deleted /tmp/.X0-lock, (there was also a /tmp/.X1-lock alongside it). That didn't work, but after I rebooted, I found that /tmp/.X0-lock was there again.

Any help would be greatly appreciated.

EDIT: Having looked at Xorg.failsafe.log, I found a lot of lines of:

(EE) FBDEV(0): FBIOPUTCMAP: Invalid argument

I have a Dell Inspiron 1545, according to sysinfo I have:

Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07) (prog-if 00 [VGA controller])

lspci gives me the same info:

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

I am using the i915 graphics driver.

  • Please post more information about your hardware (laptop make & model#, and graphics card, and whether you're running the Free or Proprietary drivers.) – Broam May 14 '12 at 14:33
  • How do I find out about the drivers? A quick google didn't help. I think they were free ones. – Peter May 14 '12 at 15:30
  • See answers to this question: askubuntu.com/questions/23238/… – Broam May 14 '12 at 15:44
  • See the link below: askubuntu.com/questions/129776/… Might help – user65357 May 22 '12 at 17:16
sudo apt-get update
sudo apt-get -d install --reinstall gdm
sudo apt-get remove --purge gdm
sudo apt-get install gdm

choose gdm when prompted

sudo reboot
  • this should work. It worked on mine! Hope it helps! – mojo706 Jun 2 '12 at 0:06
  • @tachyons Glad it did. – mojo706 Aug 6 '12 at 6:35

Unfortunately I was forced to just reinstall Ubuntu, it took a couple of hours, but reinstalling everything was easy, and it works fine now.

Anyone reading this with the same problem, make sure you backup everything, and look at this:


to reinstall your programs easily.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.