1

I have Ubuntu Server 20.04.3 LTS with KDE installed on an old PC with 2 SSDs: 1x128GB (with / and swap partitions on it) + 1x256GB exFat formated.

At some point I had Windows 7 installed on the 128GBSSD but I decided to go for Ubuntu so I cleaned up both drives using GParted.

First time I booted into the system, after installation, I noticed the Windows 10 GRUB option. I installed Grub Customizer and removed it and the second time I rebooted the system it was gone.

enter image description here

After another reboot it was back again so I decided to remove it again just that this time there was no Windows 10 option available.

enter image description here

I'm not even sure how that option got there since there was no Windows 10 installed on this PC. My guess is that this happened because I installed the OS from a USB drive that had other distros on it, along side Windows 10 and some diagnostic tools (USB created with YUMI), especially since it says that Windows installation is on /sdg1.

Any ideas on how to remove this? I can't seem to find the Windows 10 entry anywhere.

2
  • Just out of curisoity, what happens when you select it in the Grub menu? I.e., you tell the system to boot to Windows 10. If it boots to Windows, you failed to properly remove it from the system.
    – cocomac
    Oct 8 at 20:23
  • 1
    @cocomac I get "No such device... Press any key to continue" and it enters back into Grub. And it makes sense since /sdg1 does not exist in the current setup. It was the USB drive.
    – daydr3am3r
    Oct 8 at 21:14
3

I removed Windows from a dual boot setup and I also had this lingering Windows entry in the grub menu.

What finally worked to get rid of it was either one of these two things, or the combination of them:

  1. going into /boot/efi/EFI/Microsoft/Boot and renaming bootmgfw.efi to just bootmgfw
  2. using efibootmgr to remove the Windows entry

I did them on the same pass, so I don't know specifically what worked, but after this and running sudo update-grub Windows was gone forever from the menu.

1
  • 1
    Thanks. This seems to be working. Now it just boots into Ubuntu directly.
    – daydr3am3r
    Oct 9 at 7:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.