I have been using 11.10 for a month or two, and I always had these icons at the top right (mail/messenger, battery state, volume control):


After upgrading to 12.04, I lost all of these tray entries except the time. After about 5 or 6 hours of wrangling, I found that I needed to reconfigure network settings in recovery mode and whitelist every program using the tray. I managed to do this, but it's only given me network strength, Dropbox, User Accounts menu and the top-right system menu.


This is all I really need for basic operation of the system, but since I'm used to having Banshee and all my messaging services up there, I'd really appreciate being able to revert to the old settings. I have read that I need to use "Add to panel" but I can't find a way to do this anywhere. If I do right-click, alt-right-click or windows-alt-right-click on the panel, nothing happens at all, so I can't access the menu that way. Anyone with any help would be welcomed. Thanks in advance.

EDIT: Ok, after fiddling with a whole lot of things and several reboots, the missing icons have reappeared. I think what probably did it was purging and re-installing alsa, but I have no idea why. I guess that solves my problem. Now I just need to fix my microphone!

  • 1
    Since you've fixed your problem and you believe you know how, I recommend posting your solution as an answer to your own question. (You can then accept your own answer after a short time passes.) – Eliah Kagan May 14 '12 at 17:14
  • I was in the process of doing so just now but the question has been closed and I can no longer post answers. – Murmur May 14 '12 at 17:15
  • I see the question is open – Anwar May 14 '12 at 17:16
  • Ok it's open now but when I was writing my answer a message popped up saying I could not. I will answer in 4 hours when I am permitted to. Incidentally, I still can't access the "Add to Panel" menu. (Alt/Windows+Alt) + right clicking does nothing. – Murmur May 14 '12 at 17:30
  • 1
    is this gnome-classic or unity? – fossfreedom May 14 '12 at 17:53

After fiddling with a whole lot of things and several reboots, the missing icons have reappeared. I think I've figured out what happened. I had forgotten that I did the following (not sure if it's all relevant):

sudo add-apt-repository ppa:jconti/gnome3
sudo apt-get update
sudo apt-get install indicator-applet-complete
sudo reboot

I guess that solves my problem, except it would still be nice to be able to access the "Add to Panel" menu. As I said above, the special right-clicks still don't work.

  • this does not work as the add-apt-get-repository command does not even exist – Sliq Aug 29 '12 at 9:37
  • damn its awesome how messy and stupid linux is. why is it so hard to do the most simple things ? – Sliq Aug 29 '12 at 9:37
  • 1
    @Panique, maybe it was sudo add apt-get-repository ppa:jconti/gnome3 then. I don't recall, I'm afraid. Edited for formatting. – Murmur Aug 30 '12 at 10:37
  • 1
    i struggled around with this for a while, but found out it is: sudo add-apt-repository XXX – Sliq Aug 30 '12 at 11:58
  • Yes it did worked – Ravi Kumar Apr 24 '14 at 19:47

This happened to me when I upgraded from 11.10 to 12.04 but I rebooted in the middle of the installation.

After managing to finish the package installation, this exact same problem was happening to me, and I fixed it by going through Synaptic Package Manager, searching for the indicator- packages, and updating all those that can be updated (in my case, marked with a grey exclamation mark [!]). After restarting Unity, all indicators were back.


This worked for me. Go to the panel and press the buttons alt+win+right click, then add Indicator Applet Complete. Hope it works

Volume and other indicators disappeared in the classic desktop

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.