After installing logkeys from synaptic, it does not work, hangs when trying to start, even the output file is not created. Compiling solves this particular problem, but the now the output file is blank. How can i know what may be he problem? And how to solve it?

4 Answers 4


What command are you using to run it? When I tried to do

sudo logkeys --start

The program stalled for me too. I realized I needed to specify a keymap. If you have a US keyboard, you can type

sudo logkeys --start --us-keymap

For other keyboards type

sudo logkeys --start --keymap=/path/to/my/keymap.map

The fact that logkeys doesn't tell you a keymap isn't specified looks like a bug to me.


I had this problem too, so I installed with apt-get and it worked like a charm. Open terminal (Ctrl+Alt+T) and then type:

sudo apt-get install logkeys

Link to pt_br/uk_table or another language table: Keymaps

sudo logkeys -s -m /home/user/pt_BR.map -o /home/user/logkeys.log

It can be done simple steps. First open a terminal and do the following

  1. Step1: Installing logkeys using sudo apt-get install logkeys
  2. Step2: Start it by sudo logkeys --start
  3. Step3: Type anything you need, you can use cntrl, shift, etc. Logfile is stored on the location /var/log/ unless you specified -o option
  4. Step4: To view it, type sudo gedit /var/log/logkeys.log (Assume gedit installed on your system). Instead you can use sudo nano /var/log/logkeys.log

The apt-get package is broken, looks like since 12.10

It installs fine, but does not output anything to the files.

strace logkeys -s

Clearly shows the errors.

The details and confirmations of this are here https://code.google.com/p/logkeys/issues/detail?id=108

You'll have to install yourself from sources.

See https://code.google.com/p/logkeys/wiki/Documentation

I have messaged the package maintainer.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .