I have an Ubuntu 10.04.4 web server, and I have set it to run byobu on session startup.

To start with it all seems to work fine, for example F9 brings up the menu and F7 starts the copy/paste process.

When I connect to the server using PuTTY from my PC, the problem is that when I press F2 to create a new window, the screen just flashes, and no window is created.

I have tried setting PuTTY to use Xterm R6 in the function keys settings, as per the man page and mailing list, but have also tried using the default ESC[n~.

  • You don't say whether your PuTTY runs on Ubuntu or whether you merely run it, for example on Windows, to connect to Ubuntu. – 0xC0000022L May 14 '12 at 12:55
  • I'm connecting to the web server from my PC, using PuTTY. – Cylindric May 14 '12 at 13:04

Since you are using 10.04 I'll assume you are still using the screen backend to byobu. You should also learn the screen shortcuts - at least the most important ones.

  1. Ctrl+ac == create new window
  2. Ctrl+ap == previous window
  3. Ctrl+an == next window
  4. Ctrl+aa == toggle between two windows
  5. Ctrl+a[number] == switch to window [number]
  6. Ctrl+ad == detach from session

There are various reasons why this may not work. And you will encounter more the more different programs you use.

For example the default byobu shortcuts block out the ones in Midnight Commander (various F-keys), but you can use Alt+[number], e.g. Alt+1 replaces F1.

| improve this answer | |
  • Aah, okay I thought the F-keys would still work. I'm familiar with screen (it's what i've used for years) but the [Ctrl]+[a][c] does the same as [F2] - just flashes the screen. Works fine if I run screen manually, and not byobu. – Cylindric May 14 '12 at 13:01
  • Check your .screenrc and anything that gets sourced from it (did someone unbind the key?). Also consider global screen and byobu settings. btw: in my PuTTY to the same distro version I use backspace = Control-?, home = Standard, Function keys = ESC[n~ ... and both F2 and Ctrl+a c work for me. – 0xC0000022L May 14 '12 at 13:08

In Putty, You need to set the configurations: Replace the xterm with putty-256color

Connection->Data->Terminal-Type-String-> putty-256color enter image description here

Note: Go to session-> click save button to save the configuration.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.