0

I have a laptop with a broadcom network card. I keep it always powered and have some background processes. I SSH into it and daily the network disconnects at random times. I have to go to the laptop and click on the wifi and connect it manually.

03:00.0 Network controller: Broadcom Inc. and subsidiaries BCM4313 802.11bgn Wireless Network Adapter (rev 01)

My release information is:

Description:    Ubuntu 18.04.3 LTS
Release:        18.04

Any suggestions on what I should look for to solve this?

I am fine with a work around where I reboot through crontab when the network is not available (and hope that fixes it) or restart the network manager.

2
  • Look at the logs! sudo journalctl -b 0 -u NetworkManager. Read man journalctl.
    – waltinator
    Oct 4 at 3:57
  • If your system is still reporting itself at 18.04.3, you are well behind on security fixes & updates; refer fridge.ubuntu.com/2020/02/12/ubuntu-18-04-4-lts-released and you'll see when 18.04.4 ISO was released; installed systems having updated awhile before that actual ISO release date. A fully upgraded system will report itself as 18.04.6 currently. FYI: You didn't say which kernel stack you're using on your unstated desktop or server install; the other stack choice maybe an easy fix.
    – guiverc
    Oct 4 at 4:43
1

This is often the result of the power saving feature in Ubuntu. You can disable this for the WiFi device by editing a file and restarting the network manager.

Here's how:

  1. Open Terminal (if it's not already open)

  2. Edit the default-wifi-powersave-on.conf file:

    sudo vi /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
    

    Note: Feel free to use any text editor of your choice. Be sure to open it with sudo, though.

    You will see the file contents look like this:

    [connection]
    wifi.powersave = 3
    
  3. Replace 3 with 2, then save the file.

    Definition of Values:

    Value What It Means
    0 Use the default value
    1 Do not change existing setting(s)
    2 Disable powersave feature
    3 Enable powersave feature
  4. Restart the network manager:

    sudo service network-manager restart
    

    Alternatively, you could restart the entire system.

This should prevent the device from disconnecting from the network when the system believes it is idle.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.