I have a Synology NAS with various folders which I share over my network. When I start my Ubuntu laptop these network drives are mounted as read only but when I unmount and remount them using the Files application they allow read/write access. Is there a way I can mount them as read/write at startup. An example mount line in the fstab file looks like this

//192.168.y.xxx/music /media/music cifs credentials=/home/zzz/.smbcredentials,vers=default,users,rw,iocharset=utf8 0 0

Hope you can help


1 Answer 1


Hi here is a working fstab line im currently using
Please note the noauto option : do not mount until I open the folder with files.

//host/share    /media/myuser/share cifs noauto,user,_netdev,sec=ntlm,credentials=/home/myuser/creds,uid=1000,gid=1000,vers=1.0 0 0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .