3

I have a Dell Venue with an Intel CPU and Intel HD graphics card. After I suspend my PC and wake it up, the screen remains black. I can listen to the sound when I press, for example, the volume buttons, but I can't do anything.

I've already tried the following, but nothing worked:

  • Switching gdm3 to lightdm.

  • Replacing gnome-screensaver with xscreensaver.

  • Updating the kernel from 5.11 to 5.13.1.

  • Ctrl+F1 or Ctrl+F2/F3

  • Adding:

    nomodeset / nouveau.modeset=0 / nouveau.blacklist=1 /pci=nomsi 
    

    to GRUB_CMDLINE_LINUX.

  • Changing the power button function from the settings.

If I disable the s3state (sleep state) from the BIOS, it works, but the PC doesn't sleep normally and it continues to drain battery.

Info that may be useful:

  • The BIOS is updated.

  • To boot correctly, I set the following string in GRUB_CMDLINE_LINUX_DEFAULT:

    quiet acpi_osi=Linux nomodeset acpi_backlight=vendor splash
    

    Without nomodeset, Ubuntu doesn't boot. Without the rest, it is impossible to regulate the display luminosity.

  • Hibernating and waking the PC up using a live Ubuntu USB seems to work.

7
  • Do you you use gnome terminal as your default? if not, which one do you use?
    – Nate T
    Oct 3, 2021 at 17:54
  • yes, i use the Ubutuntu default Terminal
    – Perti
    Oct 3, 2021 at 18:38
  • 2
    Known bug that also affects my machine that's powered by AMD... Oct 3, 2021 at 19:28
  • @karthiknair thanks for the reply. So I deduce that we will have to wait for a fix and in the meantime use it without the possibility of suspending it.
    – Perti
    Oct 4, 2021 at 8:33
  • @Perti If you want to know how to kill the "suspend" feature altogether even when you close the laptop lid, I have a workaroud here askubuntu.com/a/1336041/1227056 Oct 4, 2021 at 18:38

4 Answers 4

0

I also have a Dell Venue - to be precise, a 10 Pro 5056 with an Atom Z8550 (Cherry Trail generation). These chipsets have freeze-after-sleep issues with the most recent kernels.

I've tested several kernels, and the stable ones regarding suspend are the 5.4 series. I'd advice installing a 5.4.1xx to have a recent enough and working kernel. Download from the Ubuntu kernel archive at https://kernel.ubuntu.com/~kernel-ppa/mainline/ - one needs 4 files, linux-headers-5.4.1xx-, linux-headers-5.4.1xx-generic, linux-image-5.4.1xx-* and linux-modules-5.4.1xx-. Download and use sudo dpkg -i linux

Also with these chipsets, sound is often an issue. I ended up using a USB-to jack adapter/sound card. Because even when sound was "sort of working", there was stereo issue.

Another issue is setting brightness, which has a huge impact on battery (altering /sys/class/backlight/intel_backlight/brightness). With some kernels, the backlight brightness cannot be changed and the battery lifetime is killed; only gamma can be set using (like xrandr --output "DSI-1" --brightness ).

List of kernels I've tested:

  • 5.4.53 brightness OK suspend OK sound OK not after suspend

  • 5.4.60 brightness OK suspend ?? sound NO

  • 5.4.75 brightness OK suspend ?? sound NO

  • 5.4.100 brightness OK suspend OK sound OK (after a while when suspend)

  • 5.4.105 brightness OK suspend OK sound NO

  • 5.4.128 brightness OK suspend OK sound sometimes

  • 5.4.130 brightness OK suspend OK sound sometimes on 21.04 - boot failure on 21.10

  • 5.4.150 boot failure on 21.10

  • 5.6.15 brightness OK suspend CRASH sound OK

  • 5.8.18 brightness OK suspend CRASH sound OK

  • 5.10.1 brightness NO suspend OK sound OK

  • 5.10.2 boot failure

  • 5.10.3 brightness NO suspend OK sound OK

  • 5.10.4 brightness OK suspend CRASH sound OK

  • 5.10.10 brightness OK suspend CRASH sound ??

  • 5.10.15 brightness OK suspend sound NO

  • 5.10.19 brightness ?? suspend ?? sound ??

  • 5.10.35 brightness OK suspend CRASH sound ??

  • 5.11.20 brightness OK suspend CRASH sound ??

  • 5.12.15 brightness OK suspend CRASH sound ??

  • 5.13.0 brightness OK suspend CRASH sound OK

  • 5.13.1 brightness OK suspend CRASH sound OK

  • 5.13.13 brightness OK suspend CRASH sound ??

  • 5.14 brightness OK suspend CRASH sound ??

2
  • I wanted to look a bit more into this: actually the system does wake up properly, except the screen. One can verify that by typing in a terminal "sleep 10; reboot", suspend then wake up the laptop: it'll reboot nicely (journalctl confirms this). Also, using the "switch to external display" has the same behavior - the internal GPU will never resume sending the image to the internal screen. I see the backlight flashing when the screen wakes up, but it stays black.
    – Sly
    Oct 20, 2021 at 14:46
  • thank you for your answer. Unfortunately i've tried 5.10.1, 5.10.3, 5.4.1 and 5.4.105, but the problem still remains. I really think there is no solution in my case
    – Perti
    Oct 24, 2021 at 11:24
0

I don't have much to add but I will say this. I chased every rabbit hole I could find w/power settings because my Kubuntu would wake but just have a black screen, never allowing me to log back in forcing me to restart.

It turned out to be my themes were broken. I found an obscure site on how to fix it, but ultimately I end up just resetting my themes back to normal and it fixed it.

1
  • 1
    I also have the same problem. How do you know whether it is because of a broken theme and how to reset to default?
    – doraemon
    Nov 27, 2021 at 1:56
0

I have Ubuntu 22.04 LTS and this same thing happened to me today. I've tried all of the things I found in different forums but nothing work. I decided to restart my laptop again and switch to Windows because I installed it along with it and decided to reboot again. When I was in the BIOS, I choose the "Advance options with Ubuntu" and instead of choosing the recovery mode, I decided to try going for the Linux Generic and when my laptop rebooted again. It showed me recovering my journal and cleaning my inorphaned inodes and after that I was able to see the login screen again after 3hrs of finding ways to fix it. I hope this answer helps!

I've also disabled the suspend option in my gnome tweaks and the same with the settings turning off the automatically suspend in both options whether it is due to inactivity or plugged in. So far, my laptop backlight is fine. I'll update this answer if ever I'll notice any other unusual changes.

UPDATE: After updating and upgrading last night and shutting down my laptop. I opened it again and decided not to try the same procedure that I did before, instead I went ahead to go boot the Ubuntu and it started smoothly without any lags or black screen.

0

my environment

user1@ubuntu-desktop1:~$ cat /etc/issue
ubuntu 22.04 LTS \n \l
user1@ubuntu-desktop1:~$ uname -r
5.15.0-30-generic
user1@ubuntu-desktop1:~$ uname -m
x86_64

my solution

user1@ubuntu-desktop1:~$ sudo apt update; sudo apt upgrade

test

user1@ubuntu-desktop1:~$ systemctl suspend

Press any keys in the mouse or keyboard

success start without black screen

New contributor
qiren ji is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.